]> matita.cs.unibo.it Git - helm.git/blobdiff - DEVEL/lablgtkmathview/debian/rules
since compat <> 3 no cmx* in the install.in bu just cm*
[helm.git] / DEVEL / lablgtkmathview / debian / rules
index 0a44aca185000d4f77ebb76987ad43c1ad7fd317..622c7ca3ccab36adae00c767eaaa4dea841a7558 100755 (executable)
@@ -1,17 +1,8 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
-
-PKGNAME = liblablgtkmathview-ocaml-dev
-
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
-HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
-DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-makebuilddir/$(PKGNAME):: ocamlinit
-
-DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAMLLIBDIR)
+include /usr/share/cdbs/1/class/ocaml.mk
+DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAML_STDLIB_DIR)
+OCAML_OCAMLDOC_PACKAGES = $(OCAML_LIBDEV_PACKAGES)
+OCAML_OCAMLDOC_FLAGS += -I $(OCAML_STDLIB_DIR)/lablgtk2
+OCAML_OCAMLDOC_FLAGS += -I $(OCAML_STDLIB_DIR)/gdome2