]> matita.cs.unibo.it Git - helm.git/blobdiff - DEVEL/lablgtkmathview/debian/rules
ready for 3.09.3 and ocaml.mk
[helm.git] / DEVEL / lablgtkmathview / debian / rules
index 0a44aca185000d4f77ebb76987ad43c1ad7fd317..89b1045980681ec0a7a50211ffa04687c899ddd9 100755 (executable)
@@ -1,17 +1,6 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/class/ocaml.mk
 
-PKGNAME = liblablgtkmathview-ocaml-dev
-
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
-HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
-DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-makebuilddir/$(PKGNAME):: ocamlinit
-
-DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAMLLIBDIR)
+DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAML_STDLIB_DIR)