]> matita.cs.unibo.it Git - helm.git/blobdiff - DEVEL/ocaml-http/debian/rules
more elegant handling of all/opt building
[helm.git] / DEVEL / ocaml-http / debian / rules
index b6652614facd9e71352ede10407cebdf7bde1268..51b217617e57053f38ee694e6f0461450b84ac00 100755 (executable)
@@ -5,9 +5,9 @@ include /usr/share/cdbs/1/class/ocaml.mk
 
 PKGNAME = libhttp-ocaml-dev
 
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)
-
-ifeq ($(HAVE_OCAMLOPT),yes)
-build/$(PKGNAME)::
-       $(MAKE) opt
+DEB_MAKE_BUILD_TARGET = all
+ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
+DEB_MAKE_BUILD_TARGET += opt
 endif
+
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)