]> matita.cs.unibo.it Git - pkg-cerco/frama-c-cost-plugin.git/blobdiff - debian/rules
wip
[pkg-cerco/frama-c-cost-plugin.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..a23fa72
--- /dev/null
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+%:
+       dh $@
+       
+override_dh_auto_configure:
+       ./configure --prefix=/usr/
+
+override_dh_auto_build:
+       # frama-c Makefiles are nuts
+       $(MAKE) || $(MAKE) || $(MAKE)
+
+override_dh_auto_install:
+       export DESTDIR=debian/tmp/usr/
+       $(MAKE) -C plugin/ install
+
+override_dh_auto_clean:
+       # clean does not work
+
+override_dh_auto_test:
+       # no test