]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/debian/rules
added debian stuff and a makefile with "dist" target
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
diff --git a/helm/DEVEL/gdome_xslt/debian/rules b/helm/DEVEL/gdome_xslt/debian/rules
new file mode 100755 (executable)
index 0000000..a4d8a5b
--- /dev/null
@@ -0,0 +1,78 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# This is the debhelper compatibility version to use.
+export DH_COMPAT=3
+
+TARGETDIR = debian/libgdome2-xslt-ocaml-dev
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+
+       cd ocaml/gdome_xslt/; ./configure
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+
+       $(MAKE) -C C/gdome_xslt/
+       $(MAKE) -C ocaml/gdome_xslt/
+       -if [ -x /usr/bin/ocamlopt ]; then \
+               $(MAKE) -C ocaml/gdome_xslt/ opt; \
+       fi
+
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       -$(MAKE) -C ocaml/gdome_xslt/ distclean
+       -$(MAKE) -C C/gdome_xslt/ clean
+
+       dh_clean
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k
+       dh_installdirs -s
+
+    # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
+       # official /var/lib/ocaml/ld.conf
+       CAMLLIB=$(CURDIR) $(MAKE) -C ocaml/gdome_xslt/ install PREFIX=$(CURDIR)/$(TARGETDIR)/usr/lib/ocaml
+
+movefiles: install
+       dh_movefiles -p libgdome2-xslt-ocaml --sourcedir=$(TARGETDIR)
+
+# Build architecture-dependent files here.
+binary-arch: build movefiles
+       dh_testdir
+       dh_testroot
+       dh_installdocs -s
+       dh_installexamples -s
+       dh_installman -s
+       dh_installinfo -s
+       dh_installchangelogs -s
+       dh_link -s
+       dh_strip -s
+       dh_compress -s
+       dh_ocamlld -p libgdome2-xslt-ocaml /usr/lib/ocaml/gdome2-xslt
+       dh_fixperms -s
+       dh_installdeb -s
+       dh_shlibdeps -s
+       dh_gencontrol -s
+       dh_md5sums -s
+       dh_builddeb -s
+
+binary: binary-arch
+.PHONY: build clean movefiles binary-arch binary install configure