]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
index 6479a0b90f8aa7f6ad3f730be1d55cbc8fa88788..52a3e2ea36d651a236917c0c593a2a519773a20c 100755 (executable)
@@ -1,58 +1,10 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+OCAMLABI := $(shell ocamlc -version)
+OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
+DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
 
-TARGETDIR = debian/libgdome2-xslt-ocaml-dev
-SHARED_LIB_PKG = libgdome2-xslt0
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       ./configure --prefix=/usr
-       touch configure-stamp
-
-build: build-stamp
-build-stamp: configure-stamp 
-       dh_testdir
-       $(MAKE)
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-       -$(MAKE) clean
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs -s
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-       dh_install --sourcedir=debian/tmp
-
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs -s
-       dh_installexamples -s
-       dh_installman -s
-       dh_installinfo -s
-       dh_installchangelogs -s
-       dh_link -s
-       dh_strip -s
-       dh_compress -s
-       dh_fixperms -s
-       dh_makeshlibs -p $(SHARED_LIB_PKG)
-       dh_installdeb -s
-       dh_shlibdeps -s
-       dh_gencontrol -s
-       dh_md5sums -s
-       dh_builddeb -s
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary install configure
+ocamlinit:
+       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done