]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/debian/rules
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
index 48dcdb7fb9e1066378f998aaae5f438f5b350899..6479a0b90f8aa7f6ad3f730be1d55cbc8fa88788 100755 (executable)
@@ -5,10 +5,8 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 TARGETDIR = debian/libgdome2-xslt-ocaml-dev
+SHARED_LIB_PKG = libgdome2-xslt0
 
 configure: configure-stamp
 configure-stamp:
@@ -35,9 +33,8 @@ install: build
        dh_clean -k
        dh_installdirs -s
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-       dh_movefiles
+       dh_install --sourcedir=debian/tmp
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
@@ -50,6 +47,7 @@ binary-arch: build install
        dh_strip -s
        dh_compress -s
        dh_fixperms -s
+       dh_makeshlibs -p $(SHARED_LIB_PKG)
        dh_installdeb -s
        dh_shlibdeps -s
        dh_gencontrol -s