]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/debian/rules
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
index c10d3e9a51c3f4379fa620b1b10022de23ca18ce..6479a0b90f8aa7f6ad3f730be1d55cbc8fa88788 100755 (executable)
@@ -5,40 +5,26 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 TARGETDIR = debian/libgdome2-xslt-ocaml-dev
+SHARED_LIB_PKG = libgdome2-xslt0
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-
-       cd ocaml/gdome_xslt/; ./configure
+       ./configure --prefix=/usr
        touch configure-stamp
 
-
 build: build-stamp
-
 build-stamp: configure-stamp 
        dh_testdir
-
-       $(MAKE) -C C/gdome_xslt/
-       $(MAKE) -C ocaml/gdome_xslt/
-       -if [ -x /usr/bin/ocamlopt ]; then \
-               $(MAKE) -C ocaml/gdome_xslt/ opt; \
-       fi
-
+       $(MAKE)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-
-       -$(MAKE) -C ocaml/gdome_xslt/ distclean
-       -$(MAKE) -C C/gdome_xslt/ clean
-
+       -$(MAKE) clean
        dh_clean
 
 install: build
@@ -46,14 +32,10 @@ install: build
        dh_testroot
        dh_clean -k
        dh_installdirs -s
+       $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+       dh_install --sourcedir=debian/tmp
 
-       $(MAKE) -C ocaml/gdome_xslt/ install PREFIX=$(CURDIR)/$(TARGETDIR)/usr/lib/ocaml
-
-movefiles: install
-       dh_movefiles -p libgdome2-xslt-ocaml --sourcedir=$(TARGETDIR)
-
-# Build architecture-dependent files here.
-binary-arch: build movefiles
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installdocs -s
@@ -64,8 +46,8 @@ binary-arch: build movefiles
        dh_link -s
        dh_strip -s
        dh_compress -s
-       dh_ocamlld -p libgdome2-xslt-ocaml /usr/lib/ocaml/gdome2-xslt
        dh_fixperms -s
+       dh_makeshlibs -p $(SHARED_LIB_PKG)
        dh_installdeb -s
        dh_shlibdeps -s
        dh_gencontrol -s
@@ -73,4 +55,4 @@ binary-arch: build movefiles
        dh_builddeb -s
 
 binary: binary-arch
-.PHONY: build clean movefiles binary-arch binary install configure
+.PHONY: build clean binary-arch binary install configure