]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
reorganization continues ...
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
diff --git a/helm/DEVEL/lablgtkmathview/debian/rules b/helm/DEVEL/lablgtkmathview/debian/rules
deleted file mode 100755 (executable)
index 832767a..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       ./configure
-
-       touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
-       dh_testdir
-
-       $(MAKE)
-       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       -$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       mkdir -p debian/tmp$(OCAMLLIBDIR)
-       $(MAKE) install PREFIX=debian/tmp$(OCAMLLIBDIR)
-
-binary-arch: build install
-       dh_install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_installinfo
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol -- -VF:OCamlABI="$(OCAMLABI)"
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-arch
-.PHONY: build clean binary-arch binary install configure