]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
When the stylesheet from TML to MathML generated a document without a root
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index f6e084d780098d7a5b695a9bd1665b3ffe875f7a..2578e3efd7431b369f61db2709cd1c71af122e89 100755 (executable)
@@ -6,7 +6,7 @@
 #export DH_VERBOSE=1
 
 # This is the debhelper compatability version to use.
-export DH_COMPAT=3
+export DH_COMPAT=4
 
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
 
@@ -24,7 +24,7 @@ build-stamp:
 
        # Add here commands to compile the package.
        $(MAKE)
-       -test -x /usr/bin/ocamlopt && $(MAKE) opt
+       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
@@ -46,7 +46,7 @@ install: build
 
        # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
        # official /var/lib/ocaml/ld.conf
-       CAMLLIB=$(CURDIR) $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml
+       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
 
 movefiles: install
        dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
@@ -68,7 +68,7 @@ binary-arch: build install
        dh_link -s
        dh_strip -s
        dh_compress -s
-       dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
+#      dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
        dh_fixperms -s
        dh_installdeb -s
        dh_shlibdeps -s