]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
* upgrade to lablgtk2
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 2578e3efd7431b369f61db2709cd1c71af122e89..5893a66221f867a69d950e7fde83218eaf29b693 100755 (executable)
@@ -5,15 +5,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAML_STDLIB_DIR = $(shell ocamlc -where)
+
+include debian/autodebian.make
 
 configure: configure-stamp
-configure-stamp:
+configure-stamp: autodebian-stamp
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -22,21 +21,20 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
        if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
-clean:
+clean: autodebian-clean
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
+distclean: clean autodebian-distclean
 
 install: build
        dh_testdir
@@ -44,18 +42,11 @@ install: build
        dh_clean -k
        dh_installdirs -s
 
-       # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
-       # official /var/lib/ocaml/ld.conf
-       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
+       $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
 
 movefiles: install
-       dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
-
-# Build architecture-independent files here.
-binary-indep: build movefiles
-# We have nothing to do by default.
+       dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
@@ -63,12 +54,10 @@ binary-arch: build install
        dh_installexamples -s
        dh_installmanpages -s
        dh_installinfo -s
-#      dh_undocumented
        dh_installchangelogs -s ChangeLog
        dh_link -s
        dh_strip -s
        dh_compress -s
-#      dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
        dh_fixperms -s
        dh_installdeb -s
        dh_shlibdeps -s
@@ -76,5 +65,5 @@ binary-arch: build install
        dh_md5sums -s
        dh_builddeb -s
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure