]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
debian package for ocaml 3.07
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 3057fad83e23d8ccbb5db421838d322aeca44d1a..5893a66221f867a69d950e7fde83218eaf29b693 100755 (executable)
@@ -6,9 +6,12 @@
 #export DH_VERBOSE=1
 
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAML_STDLIB_DIR = $(shell ocamlc -where)
+
+include debian/autodebian.make
 
 configure: configure-stamp
-configure-stamp:
+configure-stamp: autodebian-stamp
        dh_testdir
        ./configure
 
@@ -23,7 +26,7 @@ build-stamp:
 
        touch build-stamp
 
-clean:
+clean: autodebian-clean
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
@@ -31,6 +34,7 @@ clean:
        -$(MAKE) distclean
 
        dh_clean
+distclean: clean autodebian-distclean
 
 install: build
        dh_testdir
@@ -38,7 +42,7 @@ install: build
        dh_clean -k
        dh_installdirs -s
 
-       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
+       $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
 
 movefiles: install
        dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)