]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
debian version 0.0.6-6
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 1f01a99486547bb1caef553fb01287afbaaa1511..8b6ed0bb5febbb844e6584e1398737d5d8852283 100755 (executable)
@@ -5,13 +5,12 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=2
+TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAML_STDLIB_DIR = $(shell ocamlc -where)
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -20,10 +19,8 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
-       -$(MAKE) opt
-       #/usr/bin/docbook-to-man debian/lablgtkmathview.sgml > lablgtkmathview.1
+       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
@@ -32,54 +29,39 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
+distclean: clean
 
 install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs
+       dh_installdirs -s
 
-       # Add here commands to install the package into debian/lablgtkmathview.
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/lablgtkmathview/usr/lib/ocaml
+       $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
 
+movefiles: install
+       dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples
-       dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
-       dh_installinfo
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+       dh_installdocs -s
+       dh_installexamples -s
+       dh_installmanpages -s
+       dh_installinfo -s
+       dh_installchangelogs -s ChangeLog
+       dh_link -s
+       dh_strip -s
+       dh_compress -s
+       dh_fixperms -s
+       dh_installdeb -s
+       dh_shlibdeps -s
+       dh_gencontrol -s
+       dh_md5sums -s
+       dh_builddeb -s
+
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure