]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
renamed Http_client to Http_user_agent to avoid clashes with Gerd's
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 3057fad83e23d8ccbb5db421838d322aeca44d1a..8b6ed0bb5febbb844e6584e1398737d5d8852283 100755 (executable)
@@ -6,6 +6,7 @@
 #export DH_VERBOSE=1
 
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAML_STDLIB_DIR = $(shell ocamlc -where)
 
 configure: configure-stamp
 configure-stamp:
@@ -31,6 +32,7 @@ clean:
        -$(MAKE) distclean
 
        dh_clean
+distclean: clean
 
 install: build
        dh_testdir
@@ -38,7 +40,7 @@ install: build
        dh_clean -k
        dh_installdirs -s
 
-       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
+       $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
 
 movefiles: install
        dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)