]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mlminidom/debian/rules
Upgraded debian package for mlminidom 0.2.2
[helm.git] / helm / DEVEL / mlminidom / debian / rules
index f01db16c77242416231b3ccd79f85661285eb9ab..8e77d81918fb10f8a2ecbccf02b60c6570098558 100755 (executable)
@@ -8,6 +8,8 @@
 # This is the debhelper compatability version to use.
 export DH_COMPAT=2
 
+UPSTREAM_CHANGELOG = ChangeLog
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -22,7 +24,7 @@ build-stamp:
 
        # Add here commands to compile the package.
        $(MAKE)
-       -$(MAKE) opt
+       -test -x /usr/bin/ocamlopt && $(MAKE) opt
        #/usr/bin/docbook-to-man debian/mlminidom.sgml > mlminidom.1
 
        touch build-stamp
@@ -58,17 +60,17 @@ binary-arch: build install
 #      dh_installdebconf       
        dh_installdocs
        dh_installexamples
-       dh_installmenu
+#      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installpam
 #      dh_installmime
 #      dh_installinit
-       dh_installcron
-       dh_installmanpages
-       dh_installinfo
+#      dh_installcron
+#      dh_installmanpages
+#      dh_installinfo
 #      dh_undocumented
-       dh_installchangelogs ChangeLog
+       -test -s $(UPSTREAM_CHANGELOG) && dh_installchangelogs $(UPSTREAM_CHANGELOG)
        dh_link
        dh_strip
        dh_compress