]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/ocaml-http/debian/changelog
Debugging stuff removed.
[helm.git] / helm / DEVEL / ocaml-http / debian / changelog
index 0fa904ed754a9ae035baf398e1c5cd4890a9ed20..79917ba3d55d4fe2ac31188b5a10800b8cc8c512 100644 (file)
@@ -1,3 +1,34 @@
+ocaml-http (0.0.8) unstable; urgency=low
+
+  * Added support for "ancient" HTTP requests which specify no HTTP
+    version
+    - 'version' method on message now has type 'version option'
+  * Http_daemon now use debugging prints from Http_common like other
+    modules
+  * Added debugging print of requests parse error
+  * Shutdown server socket on abnormal exit (actually: uncaught
+    exceptions or SIGTERM received)
+  * Added a lot of ocamldoc documentation
+
+ -- Stefano Zacchiroli <zack@debian.org>  Fri, 10 Jan 2003 10:36:53 +0100
+
+ocaml-http (0.0.7) unstable; urgency=low
+
+  * Added support for POST requests
+  * Implemented a commont 'message' class from which 'request' and
+    'response' inherit
+  * Changed constructor of 'request' objects, requests are now buildable
+    directly (and only) from an input channel
+  * Added client IP address information to Http_request.request class
+  * Added OO daemon interfaces ("daemon" and "connection" classes)
+  * Use Pcre to perform sanity test on headers instead of home made
+    parsing
+  * Callback functions can raise Http_types.Quit to have main daemon
+    quit
+  * Case-insensitive handling of header names
+
+ -- Stefano Zacchiroli <zack@debian.org>  Wed, 25 Dec 2002 16:22:31 +0100
+
 ocaml-http (0.0.6) unstable; urgency=low
 
   * Ship multithreaded and non multithreaded cm{x,}aS
@@ -5,6 +36,7 @@ ocaml-http (0.0.6) unstable; urgency=low
     objects (new method 'paramAll')
   * Added support for 'empty' bindings in query arguments (e.g.
     "/foo?b=" or "/foo?b")
+  * Added some sanity checks
   * Bumped Standards-Version to 3.5.8
   * Use versioned dependencies lib{pcre,ocamlnet}-ocaml-dev-<version>
   * Added 'Provides libhttp-ocaml-dev-<version>'