]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/lablgtkmathview/debian/rules
mod change (-x)
[helm.git] / helm / software / DEVEL / lablgtkmathview / debian / rules
old mode 100755 (executable)
new mode 100644 (file)
index 9fca716..d7443bc
@@ -1,17 +1,7 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/makefile.mk
-
-PKGNAME = liblablgtkmathview-ocaml-dev
-
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
-HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
-DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-makebuilddir/$(PKGNAME):: ocamlinit
-
-DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAMLLIBDIR)
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/class/ocaml.mk
+DEB_MAKE_INSTALL_TARGET = install PREFIX=$(CURDIR)/debian/tmp$(OCAML_STDLIB_DIR)
+OCAML_OCAMLDOC_PACKAGES = $(OCAML_LIBDEV_PACKAGES)
+OCAML_OCAMLDOC_OCAMLFIND_FLAGS = -package lablgtk2,gdome2