]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
removed old .cvsignore files
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index 21e48854b779b5dd0bf4365916fc276c2d79e4e5..b6652614facd9e71352ede10407cebdf7bde1268 100755 (executable)
@@ -1,20 +1,11 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/class/ocaml.mk
 
 PKGNAME = libhttp-ocaml-dev
 
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
-HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
-DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-makebuilddir/$(PKGNAME):: ocamlinit
-
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAMLLIBDIR)
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)
 
 ifeq ($(HAVE_OCAMLOPT),yes)
 build/$(PKGNAME)::