]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
when auto_close is set, use flush + shutdown instead of close_out, work around an...
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index bde0727440b5c0279bbaa2a28d9a4787cf55cf84..b8493ead0adf20924472b18f33f25283e007b5c9 100755 (executable)
@@ -6,12 +6,16 @@ PKGNAME = libhttp-ocaml-dev
 
 OCAMLABI := $(shell ocamlc -version)
 OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
+OFILES_ALL := $(patsubst %.in,%,$(shell ls debian/*.in))
+OFILES := $(filter-out debian/rules, $(OFILES_ALL))
 HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
 DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
 DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAMLLIBDIR)
 
 ocamlinit:
+       for f in $(OFILES_ALL); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
+
+makebuilddir/$(PKGNAME)::
        for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
 
 ifeq ($(HAVE_OCAMLOPT),yes)