]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
exportation completed!!
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index bde0727440b5c0279bbaa2a28d9a4787cf55cf84..21e48854b779b5dd0bf4365916fc276c2d79e4e5 100755 (executable)
@@ -6,13 +6,15 @@ PKGNAME = libhttp-ocaml-dev
 
 OCAMLABI := $(shell ocamlc -version)
 OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
+OFILES := $(filter-out debian/control,$(patsubst %.in,%,$(wildcard debian/*.in)))
 HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
 DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAMLLIBDIR)
 
 ocamlinit:
        for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
+makebuilddir/$(PKGNAME):: ocamlinit
+
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAMLLIBDIR)
 
 ifeq ($(HAVE_OCAMLOPT),yes)
 build/$(PKGNAME)::