]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
* change how the ocamldoc API reference is generated: no longer use upstream
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index b6652614facd9e71352ede10407cebdf7bde1268..b86c61d2827671db9e0f7f00fb7a8bfbb376b638 100755 (executable)
@@ -4,10 +4,9 @@ include /usr/share/cdbs/1/class/makefile.mk
 include /usr/share/cdbs/1/class/ocaml.mk
 
 PKGNAME = libhttp-ocaml-dev
-
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)
-
-ifeq ($(HAVE_OCAMLOPT),yes)
-build/$(PKGNAME)::
-       $(MAKE) opt
+OCAML_OCAMLDOC_PACKAGES = $(OCAML_LIBDEV_PACKAGES)
+DEB_MAKE_BUILD_TARGET = all
+ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
+DEB_MAKE_BUILD_TARGET += opt
 endif
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)