]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
debian/rules: use ocaml.mk as a CDBS "rules" snippet
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index b6652614facd9e71352ede10407cebdf7bde1268..bc214e1572a224dd66bc38e8b084b8cd05195613 100755 (executable)
@@ -1,13 +1,12 @@
 #!/usr/bin/make -f
-include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/makefile.mk
-include /usr/share/cdbs/1/class/ocaml.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/rules/ocaml.mk
 
 PKGNAME = libhttp-ocaml-dev
-
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)
-
-ifeq ($(HAVE_OCAMLOPT),yes)
-build/$(PKGNAME)::
-       $(MAKE) opt
+OCAML_OCAMLDOC_PACKAGES = $(OCAML_LIBDEV_PACKAGES)
+DEB_MAKE_BUILD_TARGET = all
+ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
+DEB_MAKE_BUILD_TARGET += opt
 endif
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)