]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/software/DEVEL/ocaml-http/debian/rules
- add build-dep for doc generation: graphviz, texlive-latex-base,
[helm.git] / helm / software / DEVEL / ocaml-http / debian / rules
index bde0727440b5c0279bbaa2a28d9a4787cf55cf84..f342cfe2623f92f25a7ce2feb7a15740c09c4d96 100755 (executable)
@@ -1,20 +1,15 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/class/ocaml.mk
 
 PKGNAME = libhttp-ocaml-dev
 
-OCAMLABI := $(shell ocamlc -version)
-OCAMLLIBDIR := $(shell ocamlc -where)
-OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
-HAVE_OCAMLOPT := $(shell test -x /usr/bin/ocamlopt && echo "yes")
-DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
-DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAMLLIBDIR)
-
-ocamlinit:
-       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
-
-ifeq ($(HAVE_OCAMLOPT),yes)
-build/$(PKGNAME)::
-       $(MAKE) opt
+DEB_MAKE_BUILD_TARGET = all
+ifeq ($(OCAML_HAVE_OCAMLOPT),yes)
+DEB_MAKE_BUILD_TARGET += opt
 endif
+build/$(PKGNAME)::
+       $(MAKE) doc
+
+DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(CURDIR)/debian/$(PKGNAME)$(OCAML_STDLIB_DIR)