]> matita.cs.unibo.it Git - helm.git/blobdiff - pkg-matita/trunk/debian/rules
debian package for matita
[helm.git] / pkg-matita / trunk / debian / rules
diff --git a/pkg-matita/trunk/debian/rules b/pkg-matita/trunk/debian/rules
new file mode 100755 (executable)
index 0000000..7807c48
--- /dev/null
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+include /usr/share/cdbs/1/class/makefile.mk
+include /usr/share/cdbs/1/class/autotools.mk
+include /usr/share/cdbs/1/rules/debhelper.mk
+
+
+DEB_CONFIGURE_EXTRA_FLAGS := \
+  --with-runtime-dir=/usr/share/matita \
+       --prefix=/usr/ \
+       --with-dbhost=FAKE_HOST
+DEB_DESTDIR := debian/tmp/
+DEB_DH_INSTALL_SOURCEDIR := $(DEB_DESTDIR)
+DEB_MAKE_INSTALL_TARGET :=
+common-install-arch::
+       make install-arch DESTDIR=$(DEB_DESTDIR)
+common-install-indep::
+       make install-indep DESTDIR=$(DEB_DESTDIR)