]> matita.cs.unibo.it Git - helm.git/blobdiff - pkg-matita/trunk/debian/rules
fix
[helm.git] / pkg-matita / trunk / debian / rules
index 70d063137435e54d007a5bdbbe32068f89b8e01c..546caba1cb245b200e1d96a0613bbd494d7984f3 100755 (executable)
@@ -16,14 +16,10 @@ DEB_MAKE_INSTALL_TARGET :=
 
 common-install-arch::
        # install matita
-       make install-arch DESTDIR=$(DEB_DESTDIR)
+       make install-arch DESTDIR=$(DEB_DESTDIR) MATITA_CFLAGS=-noinnertypes
        # generate manpages
        mkdir -p $(DEB_DESTDIR)/usr/share/man/man1/
        MATITA_RT_BASE_DIR=debian/tmp/usr/share/matita/ \
-       help2man --name="Matita interative theorem prover" -N \
-               $(DEB_DESTDIR)/usr/share/matita/matita \
-               | gzip -9 > $(DEB_DESTDIR)/usr/share/man/man1/matita.1.gz
-       MATITA_RT_BASE_DIR=debian/tmp/usr/share/matita/ \
        help2man --name="Matita interative theorem prover - batch compiler" -N \
                $(DEB_DESTDIR)/usr/share/matita/matitac \
                | gzip -9 > $(DEB_DESTDIR)/usr/share/man/man1/matitac.1.gz
@@ -39,11 +35,9 @@ common-install-arch::
        help2man --name="Matita interative theorem prover - dependency analyzer" -N \
                $(DEB_DESTDIR)/usr/share/matita/matitadep \
                | gzip -9 > $(DEB_DESTDIR)/usr/share/man/man1/matitadep.1.gz
-       if [ -e  $(DEB_DESTDIR)/usr/share/matita/matita.opt ]; then\
-               for P in  $(DEB_DESTDIR)/usr/share/matita/*.opt; do\
-                       ln -s /usr/share/man/man1/`basename $$P .opt`.1.gz \
-                       $(DEB_DESTDIR)/usr/share/man/man1/`basename $$P`.1.gz;\
-               done;\
+       if [ -e  $(DEB_DESTDIR)/usr/share/matita/matitac.opt ]; then\
+               ln -s /usr/share/man/man1/matitac.1.gz \
+                       $(DEB_DESTDIR)/usr/share/man/man1/matitac.opt.1.gz;\
        fi
        # install .opt .byte (symlinks are installed with .install
        mkdir -p debian/matita/usr/bin/
@@ -54,6 +48,6 @@ common-install-arch::
 
 common-install-indep::
        # install matita library
-       make install-indep DESTDIR=$(DEB_DESTDIR)
+       make install-indep DESTDIR=$(DEB_DESTDIR) MATITA_CFLAGS=-noinnertypes
        # innerypes removal
-       find $(DEB_DESTDIR) -name \*.xml.types.gz -exec rm {} \;
+       find $(DEB_DESTDIR) -name \*.xml.types.gz -exec rm {} \;