]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/C++/gdome_xslt/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / gdome_xslt / C++ / gdome_xslt / Makefile.am
index bb2e2664e32724d10536c93c05e009f43ded413b..0e4b76e4ef83e48a673cbec77c4d8a3c6816c3e4 100644 (file)
@@ -1,11 +1,12 @@
 
 lib_LTLIBRARIES = libgdome_xslt_cpp_smart.la
 
+libgdome_xslt_cpp_smart_la_LIBADD = $(top_builddir)/C/gdome_xslt/libgdome_xslt.la
+
 libgdome_xslt_cpp_smart_la_LDFLAGS = -version-info @VERSION_INFO@
 
 libgdome_xslt_cpp_smart_la_SOURCES = \
-  GdomeSmartDOMXSLTStylesheet.cc \
-  gdome_xslt.c
+  GdomeSmartDOMXSLTStylesheet.cc
 
 pkginclude_HEADERS = \
   GdomeSmartDOMXSLTStylesheet.hh \
@@ -15,8 +16,4 @@ INCLUDES = \
   $(GMETADOM_CFLAGS) \
   $(LIBXSLT_CFLAGS) \
   -I$(top_srcdir) \
-  -I$(top_srcdir)/../C/gdome_xslt
-
-gdome_xslt.c: $(top_srcdir)/../C/gdome_xslt/gdome_xslt.c
-       ln -s $< $@
-
+  -I$(top_srcdir)/C/gdome_xslt