]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/Makefile.am
first moogle template checkin
[helm.git] / helm / DEVEL / gdome_xslt / Makefile.am
index a4bc4c3cc0cf769bfdb6dfcd070f8f2249a02432..5c36bb5ff8cdf0f08f2a0aff2fe365fbcd38edca 100644 (file)
@@ -1,4 +1,16 @@
+DISTDIR = @PACKAGE@-@VERSION@
 
-EXTRA_DIST = BUGS LICENSE aclocal.m4 debian/
+EXTRA_DIST = BUGS LICENSE aclocal.m4 debian/ gdome2-xslt.pc.in gdome2-xslt-cpp-smart.pc.in
 
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = gdome2-xslt.pc gdome2-xslt-cpp-smart.pc
+
+## SUBDIRS = C C++ test_files
 SUBDIRS = C C++ ocaml test_files
+
+deb: dist
+       if [ -d $(DISTDIR)/ ]; then rm -rf $(DISTDIR); else true; fi
+       tar xvzf $(DISTDIR).tar.gz
+       (cd $(DISTDIR)/ && debuild)
+       rm -rf $(DISTDIR)
+