]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/configure.ac
This commit was manufactured by cvs2svn to create branch
[helm.git] / helm / DEVEL / gdome_xslt / configure.ac
diff --git a/helm/DEVEL/gdome_xslt/configure.ac b/helm/DEVEL/gdome_xslt/configure.ac
deleted file mode 100644 (file)
index 8919353..0000000
+++ /dev/null
@@ -1,107 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT
-AC_CONFIG_SRCDIR([C/gdome_xslt/gdome_xslt.h])
-
-PACKAGE=gdome2-xslt
-VERSION=0.0.5
-VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
-AC_SUBST(VERSION_INFO)
-
-AC_PROG_CC
-AC_PROG_CXX
-AC_PROG_INSTALL
-
-AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
-AM_PROG_LIBTOOL
-
-PKG_CHECK_MODULES(GDOME, gdome2 >= 0.7.0,, AC_MSG_ERROR(could not find Gdome2))
-AC_SUBST(GDOME_CFLAGS)
-AC_SUBST(GDOME_LIBS)
-
-PKG_CHECK_MODULES(GMETADOM, gdome2-cpp-smart >= 0.1.8,, AC_MSG_ERROR(could not find GMetaDOM))
-AC_SUBST(GMETADOM_CFLAGS)
-AC_SUBST(GMETADOM_LIBS)
-
-PKG_CHECK_MODULES(LIBXSLT, libxslt,, AC_MSG_ERROR(could not find libxslt))
-AC_SUBST(LIBXSLT_CFLAGS)
-AC_SUBST(LIBXSLT_LIBS)
-
-AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
-if test $HAVE_OCAMLC = "no"; then
-  AC_MSG_ERROR(could not find ocamlc in PATH, please make sure ocaml is installed)
-else
-  OCAMLC=ocamlc
-  OCAMLSTDLIBDIR="`ocamlc -where`"
-  OCAMLSTUBDIR="`ocamlc -where`/stublibs"
-  AC_SUBST(OCAMLC)
-  AC_SUBST(OCAMLSTDLIBDIR)
-  AC_SUBST(OCAMLSTUBDIR)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLOPT, ocamlopt, yes, no)
-if test $HAVE_OCAMLOPT = "no"; then
-       AC_MSG_WARN(ocaml native libraries won't be compiled since ocamlopt was not found)
-else
-  OCAMLOPT=ocamlopt
-  AC_SUBST(OCAMLOPT)
-fi
-AM_CONDITIONAL(HAVE_OCAMLOPT_COND, test x$HAVE_OCAMLOPT = xyes)
-
-AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
-if test $HAVE_OCAMLFIND = "no"; then
-  AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
-else
-  OCAMLFIND=ocamlfind
-  AC_SUBST(OCAMLFIND)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLDEP, ocamldep, yes, no)
-if test $HAVE_OCAMLDEP = "yes"; then
-  OCAMLDEP=ocamldep
-  AC_SUBST(OCAMLDEP)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLMKLIB, ocamlmklib, yes, no)
-if test $HAVE_OCAMLMKLIB = "no"; then
-  AC_MSG_ERROR(could not find ocamlmklib in PATH, please make sure ocamlmklib is installed)
-else
-  OCAMLMKLIB=ocamlmklib
-  AC_SUBST(OCAMLMKLIB)
-fi
-
-AC_MSG_CHECKING(for gdome2 ocaml binding)
-ocamlfind query gdome2 ||
-  AC_MSG_ERROR(gdome2 not installed (according to findlib))
-MLGDOME_CFLAGS="`$OCAMLFIND query -i-format gdome2`"
-AC_SUBST(MLGDOME_CFLAGS)
-
-AC_MSG_CHECKING(for the ocaml library dir)
-OCAML_LIB_DIR=`ocamlc -where`
-AC_MSG_RESULT($OCAML_LIB_DIR)
-
-AC_CHECK_FILE(/usr/include/caml/mlvalues.h,
-       OCAML_INCLUDE_DIR=/usr/include/caml,
-       OCAML_INCLUDE_DIR=$OCAML_LIB_DIR/caml
-)
-
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-AC_SUBST(OCAML_INCLUDE_DIR)
-
-AC_CONFIG_FILES([
-  Makefile
-  C/Makefile
-  C/gdome_xslt/Makefile
-  C/test/Makefile
-  C++/gdome_xslt/Makefile
-  C++/test/Makefile
-  C++/Makefile
-  ocaml/Makefile
-  ocaml/gdome_xslt/Makefile
-  ocaml/gdome_xslt/META
-  ocaml/test/Makefile
-  gdome2-xslt.pc
-  gdome2-xslt-cpp-smart.pc
-  test_files/Makefile])
-AC_OUTPUT