]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/configure.ac
ocaml 3.09 transition
[helm.git] / helm / DEVEL / gdome_xslt / configure.ac
index bc8ab38b2f4e9458f84c7cc675191f3860f6cf1b..7542923d1a7815ef17c8e6f2793332d1c177d4a6 100644 (file)
@@ -3,7 +3,7 @@ AC_INIT
 AC_CONFIG_SRCDIR([C/gdome_xslt/gdome_xslt.h])
 
 PACKAGE=gdome2-xslt
-VERSION=0.0.3
+VERSION=0.0.7
 VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
 AC_SUBST(VERSION_INFO)
 
@@ -11,107 +11,70 @@ AC_PROG_CC
 AC_PROG_CXX
 AC_PROG_INSTALL
 
-AC_CONFIG_HEADER([config.h])
+AM_CONFIG_HEADER(config.h)
 AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
 AM_PROG_LIBTOOL
 
-GDOME_CONFIG="gdome-config"
-GDOME_MIN_VERSION=0.7.0
-AC_MSG_CHECKING(for Gdome2 libraries >= $GDOME_MIN_VERSION) 
-if test "x$GDOME_PREFIX" != "x"
-then
-       if ${GDOME_PREFIX}/bin/$GDOME_CONFIG --version > /dev/null 2>&1
-       then
-               GDOME_CONFIG=${GDOME_PREFIX}/bin/$GDOME_CONFIG
-        elif ! $GDOME_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR(Could not find Gdome2 anywhere (see config.log for details).)
-       fi
-fi
-
-vers=`$GDOME_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $GDOME_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        GDOME_LIBS="`$GDOME_CONFIG --libs`"
-        GDOME_CFLAGS="`$GDOME_CONFIG --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR(You need at least Gdome2 $GDOME_MIN_VERSION for this version of $PACKAGE)
-fi
-
+PKG_CHECK_MODULES(GDOME, gdome2 >= 0.7.0,, AC_MSG_ERROR(could not find Gdome2))
 AC_SUBST(GDOME_CFLAGS)
 AC_SUBST(GDOME_LIBS)
 
-GMETADOM_CONFIG="gmetadom-config"
-GMETADOM_MIN_VERSION=0.1.4
-AC_MSG_CHECKING(for GMetaDOM libraries >= $GMETADOM_MIN_VERSION) 
-if test "x$GMETADOM_PREFIX" != "x"
-then
-       if ${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG --version > /dev/null 2>&1
-       then
-               GMETADOM_CONFIG=${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG
-        elif ! $GMETADOM_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR(Could not find GMetaDOM anywhere (see config.log for details).)
-       fi
-fi
-
-vers=`$GMETADOM_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $GMETADOM_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        GMETADOM_LIBS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --libs`"
-        GMETADOM_CFLAGS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR(You need at least GMetaDOM $GMETADOM_MIN_VERSION for this version of $PACKAGE)
-fi
-
+PKG_CHECK_MODULES(GMETADOM, gdome2-cpp-smart >= 0.1.8,, AC_MSG_ERROR(could not find GMetaDOM))
 AC_SUBST(GMETADOM_CFLAGS)
 AC_SUBST(GMETADOM_LIBS)
 
-LIBXSLT_CONFIG="xslt-config"
-LIBXSLT_MIN_VERSION=1.0.16
-AC_MSG_CHECKING(for libxslt libraries >= $LIBXSLT_MIN_VERSION) 
-if test "x$LIBXSLT_PREFIX" != "x"
-then
-       if ${LIBXSLT_PREFIX}/bin/$LIBXSLT_CONFIG --version > /dev/null 2>&1
-       then
-               LIBXSLT_CONFIG=${LIBXSLT_PREFIX}/bin/$LIBXSLT_CONFIG
-        elif ! $LIBXSLT_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR(Could not find libxslt anywhere (see config.log for details).)
-       fi
-fi
-
-vers=`$LIBXSLT_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $LIBXSLT_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        LIBXSLT_LIBS="`$LIBXSLT_CONFIG --libs`"
-        LIBXSLT_CFLAGS="`$LIBXSLT_CONFIG --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR(You need at least libxslt $LIBXSLT_MIN_VERSION for this version of $PACKAGE)
-fi
-
+PKG_CHECK_MODULES(LIBXSLT, libxslt,, AC_MSG_ERROR(could not find libxslt))
 AC_SUBST(LIBXSLT_CFLAGS)
 AC_SUBST(LIBXSLT_LIBS)
 
 AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
 if test $HAVE_OCAMLC = "no"; then
   AC_MSG_ERROR(could not find ocamlc in PATH, please make sure ocaml is installed)
+else
+  OCAMLC=ocamlc
+  OCAMLSTDLIBDIR="`ocamlc -where`"
+  OCAMLSTUBDIR="`ocamlc -where`/stublibs"
+  AC_SUBST(OCAMLC)
+  AC_SUBST(OCAMLSTDLIBDIR)
+  AC_SUBST(OCAMLSTUBDIR)
+fi
+
+AC_CHECK_PROG(HAVE_OCAMLOPT, ocamlopt, yes, no)
+if test $HAVE_OCAMLOPT = "no"; then
+       AC_MSG_WARN(ocaml native libraries won't be compiled since ocamlopt was not found)
+else
+  OCAMLOPT=ocamlopt
+  AC_SUBST(OCAMLOPT)
 fi
+AM_CONDITIONAL(HAVE_OCAMLOPT_COND, test x$HAVE_OCAMLOPT = xyes)
 
 AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
 if test $HAVE_OCAMLFIND = "no"; then
   AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
+else
+  OCAMLFIND=ocamlfind
+  AC_SUBST(OCAMLFIND)
+fi
+
+AC_CHECK_PROG(HAVE_OCAMLDEP, ocamldep, yes, no)
+if test $HAVE_OCAMLDEP = "yes"; then
+  OCAMLDEP=ocamldep
+  AC_SUBST(OCAMLDEP)
+fi
+
+AC_CHECK_PROG(HAVE_OCAMLMKLIB, ocamlmklib, yes, no)
+if test $HAVE_OCAMLMKLIB = "no"; then
+  AC_MSG_ERROR(could not find ocamlmklib in PATH, please make sure ocamlmklib is installed)
+else
+  OCAMLMKLIB=ocamlmklib
+  AC_SUBST(OCAMLMKLIB)
 fi
 
 AC_MSG_CHECKING(for gdome2 ocaml binding)
 ocamlfind query gdome2 ||
   AC_MSG_ERROR(gdome2 not installed (according to findlib))
+MLGDOME_CFLAGS="`$OCAMLFIND query -i-format gdome2`"
+AC_SUBST(MLGDOME_CFLAGS)
 
 AC_MSG_CHECKING(for the ocaml library dir)
 OCAML_LIB_DIR=`ocamlc -where`
@@ -134,11 +97,11 @@ AC_CONFIG_FILES([
   C++/gdome_xslt/Makefile
   C++/test/Makefile
   C++/Makefile
-  C++/gdome_xslt_cpp_smart-config
   ocaml/Makefile
   ocaml/gdome_xslt/Makefile
+  ocaml/gdome_xslt/META
   ocaml/test/Makefile
-  test_files/Makefile
-  debian/Makefile])
-AC_CONFIG_COMMANDS([default],[[chmod +x C++/gdome_xslt_cpp_smart-config]],[[]])
+  gdome2-xslt.pc
+  gdome2-xslt-cpp-smart.pc
+  test_files/Makefile])
 AC_OUTPUT