]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/gdome_xslt/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / gdome_xslt / debian / rules
index a4d8a5bc743ad2cfdedc27f81412ad3329bd4815..f738c4d58fa71db80a33b1cf26f38a77bc71aaae 100755 (executable)
@@ -1,78 +1,3 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
-TARGETDIR = debian/libgdome2-xslt-ocaml-dev
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-
-       cd ocaml/gdome_xslt/; ./configure
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       $(MAKE) -C C/gdome_xslt/
-       $(MAKE) -C ocaml/gdome_xslt/
-       -if [ -x /usr/bin/ocamlopt ]; then \
-               $(MAKE) -C ocaml/gdome_xslt/ opt; \
-       fi
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       -$(MAKE) -C ocaml/gdome_xslt/ distclean
-       -$(MAKE) -C C/gdome_xslt/ clean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs -s
-
-    # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
-       # official /var/lib/ocaml/ld.conf
-       CAMLLIB=$(CURDIR) $(MAKE) -C ocaml/gdome_xslt/ install PREFIX=$(CURDIR)/$(TARGETDIR)/usr/lib/ocaml
-
-movefiles: install
-       dh_movefiles -p libgdome2-xslt-ocaml --sourcedir=$(TARGETDIR)
-
-# Build architecture-dependent files here.
-binary-arch: build movefiles
-       dh_testdir
-       dh_testroot
-       dh_installdocs -s
-       dh_installexamples -s
-       dh_installman -s
-       dh_installinfo -s
-       dh_installchangelogs -s
-       dh_link -s
-       dh_strip -s
-       dh_compress -s
-       dh_ocamlld -p libgdome2-xslt-ocaml /usr/lib/ocaml/gdome2-xslt
-       dh_fixperms -s
-       dh_installdeb -s
-       dh_shlibdeps -s
-       dh_gencontrol -s
-       dh_md5sums -s
-       dh_builddeb -s
-
-binary: binary-arch
-.PHONY: build clean movefiles binary-arch binary install configure
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk