]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/configure.in
This commit was manufactured by cvs2svn to create branch 'init'.
[helm.git] / helm / DEVEL / lablgtkmathview / configure.in
diff --git a/helm/DEVEL/lablgtkmathview/configure.in b/helm/DEVEL/lablgtkmathview/configure.in
deleted file mode 100644 (file)
index a72efd5..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-AC_INIT(gMathView.ml)
-
-PACKAGE=lablgtkmathview
-
-LABLGTKMATHVIEW_MAJOR_VERSION=0
-LABLGTKMATHVIEW_MINOR_VERSION=3
-LABLGTKMATHVIEW_MICRO_VERSION=0
-LABLGTKMATHVIEW_VERSION=$LABLGTKMATHVIEW_MAJOR_VERSION.$LABLGTKMATHVIEW_MINOR_VERSION.$LABLGTKMATHVIEW_MICRO_VERSION
-VERSION=$LABLGTKMATHVIEW_VERSION
-
-AC_CHECK_PROG(HAVE_GTKMATHVIEW, gtkmathview-config, yes, no)
-if test $HAVE_GTKMATHVIEW = "no"; then
-  AC_MSG_ERROR(could not find gtkmathview configuration script, please make sure gtkmathview is installed)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
-if test $HAVE_OCAMLC = "no"; then
-  AC_MSG_ERROR(could not find ocamlc in PATH, please make sure ocaml is installed)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
-if test $HAVE_OCAMLFIND = "no"; then
-  AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
-fi
-
-AC_MSG_CHECKING("for gdome2")
-ocamlfind query gdome2 ||
-  AC_MSG_ERROR(gdome2 not installed (according to findlib))
-
-AC_MSG_CHECKING("for lablgtk")
-ocamlfind query lablgtk ||
-  AC_MSG_ERROR(lablgtk not installed (according to findlib))
-
-AC_MSG_CHECKING("for the ocaml library dir")
-OCAML_LIB_DIR=`ocamlc -where`
-AC_MSG_RESULT($OCAML_LIB_DIR)
-
-AC_CHECK_FILE(/usr/include/caml/mlvalues.h,
-       OCAML_INCLUDE_DIR=/usr/include/caml,
-       OCAML_INCLUDE_DIR=$OCAML_LIB_DIR/caml
-)
-
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-AC_SUBST(OCAML_INCLUDE_DIR)
-AC_SUBST(OCAML_LIB_DIR)
-
-AC_OUTPUT([
-  test/Makefile
-  Makefile
-  lablgtkmathview.spec
-  META
-])