]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 601b933c415e300629ed21708f05a12ee3300f74..3057fad83e23d8ccbb5db421838d322aeca44d1a 100755 (executable)
@@ -5,15 +5,11 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -22,9 +18,8 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
-       -test -x /usr/bin/ocamlopt && $(MAKE) opt
+       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
@@ -33,7 +28,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
@@ -44,18 +38,11 @@ install: build
        dh_clean -k
        dh_installdirs -s
 
-       # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
-       # official /var/lib/ocaml/ld.conf
        $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
 
 movefiles: install
-       dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
-
-# Build architecture-independent files here.
-binary-indep: build movefiles
-# We have nothing to do by default.
+       dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
@@ -63,12 +50,10 @@ binary-arch: build install
        dh_installexamples -s
        dh_installmanpages -s
        dh_installinfo -s
-#      dh_undocumented
        dh_installchangelogs -s ChangeLog
        dh_link -s
        dh_strip -s
        dh_compress -s
-#      dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
        dh_fixperms -s
        dh_installdeb -s
        dh_shlibdeps -s
@@ -76,5 +61,5 @@ binary-arch: build install
        dh_md5sums -s
        dh_builddeb -s
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure