]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 1f01a99486547bb1caef553fb01287afbaaa1511..832767abbe788849c7bf761960ba930399005707 100755 (executable)
@@ -5,13 +5,15 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=2
+OCAMLABI := $(shell ocamlc -version)
+OCAMLLIBDIR := $(shell ocamlc -where)
+OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
 
+ocamlinit:
+       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -20,10 +22,8 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
-       -$(MAKE) opt
-       #/usr/bin/docbook-to-man debian/lablgtkmathview.sgml > lablgtkmathview.1
+       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
@@ -32,7 +32,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
@@ -43,43 +42,27 @@ install: build
        dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/lablgtkmathview.
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/lablgtkmathview/usr/lib/ocaml
+       mkdir -p debian/tmp$(OCAMLLIBDIR)
+       $(MAKE) install PREFIX=debian/tmp$(OCAMLLIBDIR)
 
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build install
+       dh_install
        dh_testdir
        dh_testroot
-#      dh_installdebconf       
        dh_installdocs
        dh_installexamples
-       dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-       dh_installcron
-       dh_installmanpages
+       dh_installman
        dh_installinfo
-#      dh_undocumented
        dh_installchangelogs ChangeLog
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
-#      dh_perl
        dh_shlibdeps
-       dh_gencontrol
+       dh_gencontrol -- -VF:OCamlABI="$(OCAMLABI)"
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure