]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index 2578e3efd7431b369f61db2709cd1c71af122e89..832767abbe788849c7bf761960ba930399005707 100755 (executable)
@@ -5,15 +5,15 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
-TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAMLABI := $(shell ocamlc -version)
+OCAMLLIBDIR := $(shell ocamlc -where)
+OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
 
+ocamlinit:
+       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -22,7 +22,6 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
        if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
@@ -33,7 +32,6 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
@@ -42,39 +40,29 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k
-       dh_installdirs -s
-
-       # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
-       # official /var/lib/ocaml/ld.conf
-       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml/3.06
+       dh_installdirs
 
-movefiles: install
-       dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
+       mkdir -p debian/tmp$(OCAMLLIBDIR)
+       $(MAKE) install PREFIX=debian/tmp$(OCAMLLIBDIR)
 
-# Build architecture-independent files here.
-binary-indep: build movefiles
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build install
+       dh_install
        dh_testdir
        dh_testroot
-       dh_installdocs -s
-       dh_installexamples -s
-       dh_installmanpages -s
-       dh_installinfo -s
-#      dh_undocumented
-       dh_installchangelogs -s ChangeLog
-       dh_link -s
-       dh_strip -s
-       dh_compress -s
-#      dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
-       dh_fixperms -s
-       dh_installdeb -s
-       dh_shlibdeps -s
-       dh_gencontrol -s
-       dh_md5sums -s
-       dh_builddeb -s
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+       dh_installdocs
+       dh_installexamples
+       dh_installman
+       dh_installinfo
+       dh_installchangelogs ChangeLog
+       dh_link
+       dh_strip
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_shlibdeps
+       dh_gencontrol -- -VF:OCamlABI="$(OCAMLABI)"
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure