]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtkmathview/debian/rules
first moogle template checkin
[helm.git] / helm / DEVEL / lablgtkmathview / debian / rules
index c73636002cbae24ef49b1da6ab826e24736cbfff..8b6ed0bb5febbb844e6584e1398737d5d8852283 100755 (executable)
@@ -5,15 +5,12 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
 TARGETDIR = debian/liblablgtkmathview-ocaml-dev
+OCAML_STDLIB_DIR = $(shell ocamlc -where)
 
 configure: configure-stamp
 configure-stamp:
        dh_testdir
-       # Add here commands to configure the package.
        ./configure
 
        touch configure-stamp
@@ -22,9 +19,8 @@ build: configure-stamp build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
        $(MAKE)
-       -test -x /usr/bin/ocamlopt && $(MAKE) opt
+       if [ -x /usr/bin/ocamlopt ]; then $(MAKE) opt; else true; fi
 
        touch build-stamp
 
@@ -33,10 +29,10 @@ clean:
        dh_testroot
        rm -f build-stamp configure-stamp
 
-       # Add here commands to clean up after the build process.
        -$(MAKE) distclean
 
        dh_clean
+distclean: clean
 
 install: build
        dh_testdir
@@ -44,18 +40,11 @@ install: build
        dh_clean -k
        dh_installdirs -s
 
-       # trick: redifine CAMLLIB so that findlibd doesn't try to modify the
-       # official /var/lib/ocaml/ld.conf
-       $(MAKE) install PREFIX=$(TARGETDIR)/usr/lib/ocaml
+       $(MAKE) install PREFIX=$(TARGETDIR)$(OCAML_STDLIB_DIR)
 
 movefiles: install
-       dh_movefiles -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
-
-# Build architecture-independent files here.
-binary-indep: build movefiles
-# We have nothing to do by default.
+       dh_install -p liblablgtkmathview-ocaml --sourcedir=$(TARGETDIR)
 
-# Build architecture-dependent files here.
 binary-arch: build install
        dh_testdir
        dh_testroot
@@ -63,12 +52,10 @@ binary-arch: build install
        dh_installexamples -s
        dh_installmanpages -s
        dh_installinfo -s
-#      dh_undocumented
        dh_installchangelogs -s ChangeLog
        dh_link -s
        dh_strip -s
        dh_compress -s
-       dh_ocamlld -p liblablgtkmathview-ocaml /usr/lib/ocaml/lablgtkmathview
        dh_fixperms -s
        dh_installdeb -s
        dh_shlibdeps -s
@@ -76,5 +63,5 @@ binary-arch: build install
        dh_md5sums -s
        dh_builddeb -s
 
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+binary: binary-arch
+.PHONY: build clean binary-arch binary install configure