]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/lablgtksourceview/debian/rules
ocaml 3.09 transition
[helm.git] / helm / DEVEL / lablgtksourceview / debian / rules
index f738c4d58fa71db80a33b1cf26f38a77bc71aaae..52a3e2ea36d651a236917c0c593a2a519773a20c 100755 (executable)
@@ -1,3 +1,10 @@
 #!/usr/bin/make -f
 include /usr/share/cdbs/1/rules/debhelper.mk
 include /usr/share/cdbs/1/class/autotools.mk
+
+OCAMLABI := $(shell ocamlc -version)
+OFILES := $(patsubst %.in,%,$(shell ls debian/*.in))
+DEB_DH_GENCONTROL_ARGS = -- -VF:OCamlABI="$(OCAMLABI)"
+
+ocamlinit:
+       for f in $(OFILES); do sed -e 's/@OCamlABI@/$(OCAMLABI)/g' $$f.in > $$f; done