]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/Makefile.am
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / mathml_editor / Makefile.am
index 63f89fc1fa7cc9e02b5a055099332bffdddc58a0..01765d571559af13492b1e3f30681c0b7616fdf0 100644 (file)
@@ -1,5 +1,7 @@
-#EXTRA_DIST = BUGS HISTORY LICENSE aclocal.m4 debian/
-SUBDIRS = src test ocaml textomml
+DISTDIR = @PACKAGE@-@VERSION@
+
+EXTRA_DIST = BUGS LICENSE BUGS-GDOME2 MODES PATTERNS aclocal.m4 debian/ editex.pc.in
+SUBDIRS = src test ocaml textomml xsl dict
 CLEANFILES = core
 
 pkgconfigdir = $(libdir)/pkgconfig
@@ -20,3 +22,10 @@ lc:
        ICCFILES=`find . -name "*.icc"`; \
        wc -l $$CFILES $$HFILES $$CCFILES $$HHFILES $$ICCFILES | tail -n 1 \
        )
+
+deb: dist
+       if [ -d $(DISTDIR)/ ]; then rm -rf $(DISTDIR); else true; fi
+       tar xvzf $(DISTDIR).tar.gz
+       (cd $(DISTDIR)/ && debuild)
+       rm -rf $(DISTDIR)
+