]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / Makefile.am
index 63f89fc1fa7cc9e02b5a055099332bffdddc58a0..aa15ecbef9755095b82ee5157121e4c8f14208d2 100644 (file)
@@ -1,5 +1,7 @@
-#EXTRA_DIST = BUGS HISTORY LICENSE aclocal.m4 debian/
-SUBDIRS = src test ocaml textomml
+DISTDIR = @PACKAGE@-@VERSION@
+
+EXTRA_DIST = BUGS LICENSE BUGS-GDOME2 MODES PATTERNS aclocal.m4 editex.pc.in debian
+SUBDIRS = src test ocaml textomml xsl dict
 CLEANFILES = core
 
 pkgconfigdir = $(libdir)/pkgconfig
@@ -20,3 +22,10 @@ lc:
        ICCFILES=`find . -name "*.icc"`; \
        wc -l $$CFILES $$HFILES $$CCFILES $$HHFILES $$ICCFILES | tail -n 1 \
        )
+
+deb: dist
+       if [ -d $(DISTDIR)/ ]; then rm -rf $(DISTDIR); else true; fi
+       tar xvzf $(DISTDIR).tar.gz
+       (cd $(DISTDIR)/ && rm -rf debian/CVS/ && debuild)
+       rm -rf $(DISTDIR)
+