]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/configure.ac
This commit was manufactured by cvs2svn to create branch
[helm.git] / helm / DEVEL / mathml_editor / configure.ac
diff --git a/helm/DEVEL/mathml_editor/configure.ac b/helm/DEVEL/mathml_editor/configure.ac
deleted file mode 100644 (file)
index 49662e3..0000000
+++ /dev/null
@@ -1,181 +0,0 @@
-dnl Process this file with autoconf to produce a configure script.
-AC_INIT(editex, [0.0.3])
-AC_CONFIG_SRCDIR(src/TToken.hh)
-AM_INIT_AUTOMAKE($AC_PACKAGE_NAME, $AC_PACKAGE_VERSION)
-
-PACKAGE=$PACKAGE_NAME
-VERSION=$PACKAGE_VERSION
-AC_SUBST(PACKAGE)
-AC_SUBST(VERSION)
-
-EDITEX_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
-AC_SUBST(EDITEX_VERSION_INFO)
-
-AC_ARG_ENABLE(
-       profile,
-       [  --enable-profile[=ARG]  include profiling information [default=no]],
-       profile=$enableval,
-       profile=no
-)
-
-AC_ARG_ENABLE(
-       debug,
-       [  --enable-debug[=ARG]    include debugging debug [default=yes]],
-       enable_debug=$enableval,
-       enable_debug=yes
-)
-
-if test "x$enable_debug" = "xyes"; then
-   AC_DEFINE(ENABLE_DEBUG,,[Define to 1 if you want to enable validity checks while running])
-fi
-
-GMETADOM_PREFIX=""
-AC_ARG_WITH(gmetadom-prefix,
-        [  --with-gmetadom-prefix=[PFX]         Specify location of gmetadom],
-       GMETADOM_PREFIX=$withval
-)
-
-dnl AC_CONFIG_HEADERS([config.h])
-AM_CONFIG_HEADER(config.h)
-
-AH_TOP([
-/* This file is part of EdiTeX, an editor of mathematical
- * expressions based on TeX syntax.
- * 
- * Copyright (C) 2002-2003 Luca Padovani <lpadovan@cs.unibo.it>,
- *                    2003 Paolo Marinelli <pmarinel@cs.unibo.it>.
- *
- * This library is free software; you can redistribute it and/or
- * modify it under the terms of the GNU Lesser General Public
- * License as published by the Free Software Foundation; either
- * version 2.1 of the License, or (at your option) any later version.
- *
- * This library is distributed in the hope that it will be useful,
- * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
- * Lesser General Public License for more details.
- *
- * You should have received a copy of the GNU Lesser General Public
- * License along with this library; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
- *
- * For more information, please visit the project's home page
- * http://helm.cs.unibo.it/editex/
- * or send an email to <lpadovan@cs.unibo.it>
- */
-
-#ifndef config_h
-#define config_h
-])
-
-AH_BOTTOM([
-#endif /* config_h */
-])
-
-AC_PROG_CC
-AC_PROG_CXX
-AC_PROG_INSTALL
-AC_HEADER_STDC([])
-
-AC_LANG_PUSH(C++)
-AC_CHECK_HEADERS(hash_map)
-AC_CHECK_HEADERS(ext/hash_map)
-AC_LANG_POP(C++)
-
-AC_SUBST(CFLAGS)
-AC_SUBST(CPPFLAGS)
-AC_SUBST(LDFLAGS)
-
-AM_PROG_LIBTOOL
-
-dnl PKG_CHECK_MODULES(GLIB2, glib-2.0)
-dnl AC_SUBST(GLIB2_CFLAGS)
-dnl AC_SUBST(GLIB2_LIBS)
-
-PKG_CHECK_MODULES(GMETADOM,gdome2-cpp-smart,,AC_MSG_ERROR(can not find gmetadom))
-AC_SUBST(GMETADOM_CFLAGS)
-AC_SUBST(GMETADOM_LIBS)
-
-PKG_CHECK_MODULES(GDOMEXSLT,gdome2-xslt-cpp-smart,,AC_MSG_ERROR(can not find gdome2-xslt))
-AC_SUBST(GDOMEXSLT_CFLAGS)
-AC_SUBST(GDOMEXSLT_LIBS)
-
-PKG_CHECK_MODULES(GTKMATHVIEW,gtkmathview,,AC_MSG_ERROR(can not find gtkmathview))
-AC_SUBST(GTKMATHVIEW_CFLAGS)
-AC_SUBST(GTKMATHVIEW_LIBS)
-
-AC_CHECK_PROG(HAVE_OCAMLC, ocamlc, yes, no)
-if test $HAVE_OCAMLC = "no"; then
-  AC_MSG_ERROR([could not find ocamlc in PATH, please make sure ocaml is installed])
-else
-  OCAMLC=ocamlc
-  OCAMLSTDLIBDIR="`ocamlc -where`"
-  OCAMLSTUBDIR="`ocamlc -where`/stublibs"
-  AC_SUBST(OCAMLC)
-  AC_SUBST(OCAMLSTDLIBDIR)
-  AC_SUBST(OCAMLSTUBDIR)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLOPT, ocamlopt, yes, no)
-if test $HAVE_OCAMLOPT = "no"; then
-       AC_MSG_WARN([ocaml native libraries won't be compiled since ocamlopt was not found])
-else
-  OCAMLOPT=ocamlopt
-  AC_SUBST(OCAMLOPT)
-fi
-AM_CONDITIONAL(HAVE_OCAMLOPT_COND, test x$HAVE_OCAMLOPT = xyes)
-
-AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
-if test $HAVE_OCAMLFIND = "no"; then
-  AC_MSG_ERROR([could not find ocamlfind in PATH, please make sure findlib is installed])
-else
-  OCAMLFIND=ocamlfind
-  AC_SUBST(OCAMLFIND)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLDEP, ocamldep, yes, no)
-if test $HAVE_OCAMLDEP = "yes"; then
-  OCAMLDEP=ocamldep
-  AC_SUBST(OCAMLDEP)
-fi
-
-AC_CHECK_PROG(HAVE_OCAMLMKLIB, ocamlmklib, yes, no)
-if test $HAVE_OCAMLMKLIB = "no"; then
-  AC_MSG_ERROR([could not find ocamlmklib in PATH, please make sure ocamlmklib is installed])
-else
-  OCAMLMKLIB=ocamlmklib
-  AC_SUBST(OCAMLMKLIB)
-fi
-AM_CONDITIONAL(HAVE_SHAREDLIBS_COND, test x$enable_shared = xyes)
-
-AC_MSG_CHECKING(for gdome2 ocaml binding)
-ocamlfind query gdome2 ||
-  AC_MSG_ERROR(gdome2 not installed (according to findlib))
-MLGDOME_CFLAGS="`$OCAMLFIND query -i-format gdome2`"
-AC_SUBST(MLGDOME_CFLAGS)
-
-AC_MSG_CHECKING(for the ocaml library dir)
-OCAML_LIB_DIR=`ocamlc -where`
-AC_MSG_RESULT($OCAML_LIB_DIR)
-
-AC_CHECK_FILE(/usr/include/caml/mlvalues.h,
-       OCAML_INCLUDE_DIR=/usr/include/caml,
-       OCAML_INCLUDE_DIR=$OCAML_LIB_DIR/caml
-)
-
-AC_SUBST(OCAML_INCLUDE_DIR)
-
-AC_CONFIG_FILES([
- Makefile 
- src/Makefile
- src/config.dirs
- test/Makefile
- textomml/Makefile
- textomml/config.dirs
- ocaml/Makefile
- ocaml/META
- editex.pc
- xsl/Makefile
- dict/Makefile
-])
-AC_OUTPUT