]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/configure.ac
Initial revision
[helm.git] / helm / DEVEL / mathml_editor / configure.ac
diff --git a/helm/DEVEL/mathml_editor/configure.ac b/helm/DEVEL/mathml_editor/configure.ac
new file mode 100644 (file)
index 0000000..0dca72c
--- /dev/null
@@ -0,0 +1,181 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_INIT
+AC_CONFIG_SRCDIR([src/TToken.hh])
+
+PACKAGE=editex
+VERSION=0.0.1
+EDITEX_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
+AC_SUBST(EDITEX_VERSION_INFO)
+
+AC_ARG_ENABLE(
+       profile,
+       [  --enable-profile[=ARG]  include profiling information [default=no]],
+       profile=$enableval,
+       profile=no
+)
+
+AC_ARG_ENABLE(
+       debug,
+       [  --enable-debug[=ARG]    include debugging debug [default=yes]],
+       enable_debug=$enableval,
+       enable_debug=yes
+)
+
+if test "x$enable_debug" = "xyes"; then
+   AC_DEFINE(ENABLE_DEBUG,,[Define to 1 if you want to enable validity checks while running])
+fi
+
+GMETADOM_PREFIX=""
+AC_ARG_WITH(gmetadom-prefix,
+        [  --with-gmetadom-prefix=[PFX]         Specify location of gmetadom],
+       GMETADOM_PREFIX=$withval
+)
+
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+AM_CONFIG_HEADER(config.h)
+
+AH_TOP([
+/* Copyright (C) 2002, Luca Padovani <luca.padovani@cs.unibo.it>.
+ *
+ * This file is part of EdiTeX, an editor of mathematical
+ * expressions based on TeX syntax
+ * 
+ * EdiTeX is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU General Public License
+ * as published by the Free Software Foundation; either version 2
+ * of the License, or (at your option) any later version.
+ *
+ * EdiTeX is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with EdiTeX; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
+ * 
+ * For details, see the EdiTeX World-Wide-Web page,
+ * http://helm.cs.unibo.it/editex, or send a mail to
+ * <luca.padovani@cs.unibo.it>
+ */
+#ifndef config_h
+#define config_h
+])
+
+AH_BOTTOM([
+#endif /* config_h */
+])
+
+AC_PROG_CC
+AC_PROG_CXX
+AC_PROG_INSTALL
+AC_HEADER_STDC([])
+
+AC_SUBST(CFLAGS)
+AC_SUBST(CPPFLAGS)
+AC_SUBST(LDFLAGS)
+
+AM_PROG_LIBTOOL
+
+GMETADOM_CONFIG="gmetadom-config"
+GMETADOM_MIN_VERSION=0.1.0
+AC_MSG_CHECKING([for GMetaDOM C++ library] >= $GMETADOM_MIN_VERSION) 
+if test "x$GMETADOM_PREFIX" != "x"
+then
+       if ${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG --version > /dev/null 2>&1
+       then
+               GMETADOM_CONFIG=${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG
+        elif ! $GMETADOM_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gmetadom anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GMETADOM_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GMETADOM_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GMETADOM_LIBS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --libs`"
+        GMETADOM_CFLAGS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least GMetaDOM (C++) $GMETADOM_MIN_VERSION for this version of $PACKAGE])
+fi
+
+AC_SUBST(GMETADOM_CFLAGS)
+AC_SUBST(GMETADOM_LIBS)
+
+GDOMEXSLT_CONFIG="gdome_xslt_cpp_smart-config"
+GDOMEXSLT_MIN_VERSION=0.0.1
+AC_MSG_CHECKING([for gdome_xslt C++ library] >= $GDOMEXSLT_MIN_VERSION) 
+if test "x$GDOMEXSLT_PREFIX" != "x"
+then
+       if ${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG --version > /dev/null 2>&1
+       then
+               GDOMEXSLT_CONFIG=${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG
+        elif ! $GDOMEXSLT_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gdome_xslt anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GDOMEXSLT_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GDOMEXSLT_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GDOMEXSLT_LIBS="`$GDOMEXSLT_CONFIG --libs`"
+        GDOMEXSLT_CFLAGS="`$GDOMEXSLT_CONFIG --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least gdome_xslt (C++) $GDOMEXSLT_MIN_VERSION for this version of $PACKAGE])
+fi
+
+AC_SUBST(GDOMEXSLT_CFLAGS)
+AC_SUBST(GDOMEXSLT_LIBS)
+
+GTKMATHVIEW_CONFIG="gtkmathview-config"
+GTKMATHVIEW_MIN_VERSION=0.4.0
+AC_MSG_CHECKING([for gtkmathview library] >= $GTKMATHVIEW_MIN_VERSION) 
+if test "x$GTKMATHVIEW_PREFIX" != "x"
+then
+       if ${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
+       then
+               GTKMATHVIEW_CONFIG=${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG
+        elif ! $GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gtkmathview anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GTKMATHVIEW_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GTKMATHVIEW_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GTKMATHVIEW_LIBS="`$GTKMATHVIEW_CONFIG --libs`"
+        GTKMATHVIEW_CFLAGS="`$GTKMATHVIEW_CONFIG --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least gtkmathview $GTKMATHVIEW_MIN_VERSION for this version of $PACKAGE])
+fi
+
+AC_SUBST(GTKMATHVIEW_CFLAGS)
+AC_SUBST(GTKMATHVIEW_LIBS)
+
+AC_CONFIG_FILES([
+ Makefile 
+ src/Makefile
+ test/Makefile
+ editex-config
+])
+AC_CONFIG_COMMANDS([default],[[chmod +x editex-config]],[[]])
+AC_OUTPUT