]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/configure.ac
This commit was manufactured by cvs2svn to create tag 'v0_0_2'.
[helm.git] / helm / DEVEL / mathml_editor / configure.ac
index 49662e3c3646532fdbc18814e03d2b8bff79cdb4..1defca274d6cd3ed907564c08028e8e7d4aa127d 100644 (file)
@@ -1,5 +1,5 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_INIT(editex, [0.0.3])
+AC_INIT(editex, [0.0.1])
 AC_CONFIG_SRCDIR(src/TToken.hh)
 AM_INIT_AUTOMAKE($AC_PACKAGE_NAME, $AC_PACKAGE_VERSION)
 
@@ -92,15 +92,96 @@ dnl PKG_CHECK_MODULES(GLIB2, glib-2.0)
 dnl AC_SUBST(GLIB2_CFLAGS)
 dnl AC_SUBST(GLIB2_LIBS)
 
-PKG_CHECK_MODULES(GMETADOM,gdome2-cpp-smart,,AC_MSG_ERROR(can not find gmetadom))
+GMETADOM_CONFIG="gmetadom-config"
+GMETADOM_MIN_VERSION=0.1.0
+AC_MSG_CHECKING([for GMetaDOM C++ library] >= $GMETADOM_MIN_VERSION) 
+if test "x$GMETADOM_PREFIX" != "x"
+then
+       if ${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG --version > /dev/null 2>&1
+       then
+               GMETADOM_CONFIG=${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG
+        elif ! $GMETADOM_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gmetadom anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GMETADOM_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GMETADOM_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GMETADOM_LIBS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --libs`"
+        GMETADOM_CFLAGS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least GMetaDOM (C++) $GMETADOM_MIN_VERSION for this version of $PACKAGE])
+fi
+
 AC_SUBST(GMETADOM_CFLAGS)
 AC_SUBST(GMETADOM_LIBS)
 
-PKG_CHECK_MODULES(GDOMEXSLT,gdome2-xslt-cpp-smart,,AC_MSG_ERROR(can not find gdome2-xslt))
+GDOMEXSLT_CONFIG="gdome_xslt_cpp_smart-config"
+GDOMEXSLT_MIN_VERSION=0.0.4
+AC_MSG_CHECKING([for gdome_xslt C++ library] >= $GDOMEXSLT_MIN_VERSION) 
+if test "x$GDOMEXSLT_PREFIX" != "x"
+then
+       if ${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG --version > /dev/null 2>&1
+       then
+               GDOMEXSLT_CONFIG=${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG
+        elif ! $GDOMEXSLT_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gdome_xslt anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GDOMEXSLT_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GDOMEXSLT_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GDOMEXSLT_LIBS="`$GDOMEXSLT_CONFIG --libs`"
+        GDOMEXSLT_CFLAGS="`$GDOMEXSLT_CONFIG --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least gdome_xslt (C++) $GDOMEXSLT_MIN_VERSION for this version of $PACKAGE])
+fi
+
 AC_SUBST(GDOMEXSLT_CFLAGS)
 AC_SUBST(GDOMEXSLT_LIBS)
 
-PKG_CHECK_MODULES(GTKMATHVIEW,gtkmathview,,AC_MSG_ERROR(can not find gtkmathview))
+GTKMATHVIEW_CONFIG="gtkmathview-config"
+GTKMATHVIEW_MIN_VERSION=0.4.0
+AC_MSG_CHECKING([for gtkmathview library] >= $GTKMATHVIEW_MIN_VERSION) 
+if test "x$GTKMATHVIEW_PREFIX" != "x"
+then
+       if ${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
+       then
+               GTKMATHVIEW_CONFIG=${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG
+        elif ! $GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
+        then
+               AC_MSG_ERROR([Could not find gtkmathview anywhere (see config.log for details).])
+       fi
+fi
+
+dnl
+dnl test version and init our variables
+dnl
+vers=`$GTKMATHVIEW_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+minvers=`echo $GTKMATHVIEW_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+if test "$vers" -ge "$minvers"
+then
+        GTKMATHVIEW_LIBS="`$GTKMATHVIEW_CONFIG --libs`"
+        GTKMATHVIEW_CFLAGS="`$GTKMATHVIEW_CONFIG --cflags`"
+        AC_MSG_RESULT(found)
+else
+        AC_MSG_ERROR([You need at least gtkmathview $GTKMATHVIEW_MIN_VERSION for this version of $PACKAGE])
+fi
+
 AC_SUBST(GTKMATHVIEW_CFLAGS)
 AC_SUBST(GTKMATHVIEW_LIBS)