]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/configure.ac
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / configure.ac
index be109d69c013a55db0db2074af5326291a9aff6f..e1972fd90446f30d6d6074f14ae224287d020ce8 100644 (file)
@@ -1,9 +1,13 @@
 dnl Process this file with autoconf to produce a configure script.
-AC_INIT
-AC_CONFIG_SRCDIR([src/TToken.hh])
+AC_INIT(editex, [0.0.5])
+AC_CONFIG_SRCDIR(src/TToken.hh)
+AM_INIT_AUTOMAKE($AC_PACKAGE_NAME, $AC_PACKAGE_VERSION)
+
+PACKAGE=$PACKAGE_NAME
+VERSION=$PACKAGE_VERSION
+AC_SUBST(PACKAGE)
+AC_SUBST(VERSION)
 
-PACKAGE=editex
-VERSION=0.0.1
 EDITEX_VERSION_INFO=`echo $VERSION | awk -F. '{ printf "%d:%d:%d", $1+$2, $3, $2 }'`
 AC_SUBST(EDITEX_VERSION_INFO)
 
@@ -31,34 +35,35 @@ AC_ARG_WITH(gmetadom-prefix,
        GMETADOM_PREFIX=$withval
 )
 
-AC_CONFIG_HEADERS([config.h])
-AM_INIT_AUTOMAKE($PACKAGE, $VERSION)
+dnl AC_CONFIG_HEADERS([config.h])
 AM_CONFIG_HEADER(config.h)
 
 AH_TOP([
-/* Copyright (C) 2002, Luca Padovani <luca.padovani@cs.unibo.it>.
- *
- * This file is part of EdiTeX, an editor of mathematical
- * expressions based on TeX syntax
+/* This file is part of EdiTeX, an editor of mathematical
+ * expressions based on TeX syntax.
  * 
- * EdiTeX is free software; you can redistribute it and/or
- * modify it under the terms of the GNU General Public License
- * as published by the Free Software Foundation; either version 2
- * of the License, or (at your option) any later version.
+ * Copyright (C) 2002-2004 Luca Padovani <lpadovan@cs.unibo.it>,
+ *                    2003 Paolo Marinelli <pmarinel@cs.unibo.it>.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+ * License as published by the Free Software Foundation; either
+ * version 2.1 of the License, or (at your option) any later version.
  *
- * EdiTeX is distributed in the hope that it will be useful,
+ * This library is distributed in the hope that it will be useful,
  * but WITHOUT ANY WARRANTY; without even the implied warranty of
- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- * GNU General Public License for more details.
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
+ * Lesser General Public License for more details.
  *
- * You should have received a copy of the GNU General Public License
- * along with EdiTeX; if not, write to the Free Software
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
- * 
- * For details, see the EdiTeX World-Wide-Web page,
- * http://helm.cs.unibo.it/editex, or send a mail to
- * <luca.padovani@cs.unibo.it>
+ * You should have received a copy of the GNU Lesser General Public
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
+ *
+ * For more information, please visit the project's home page
+ * http://helm.cs.unibo.it/editex/
+ * or send an email to <lpadovan@cs.unibo.it>
  */
+
 #ifndef config_h
 #define config_h
 ])
@@ -83,96 +88,19 @@ AC_SUBST(LDFLAGS)
 
 AM_PROG_LIBTOOL
 
-GMETADOM_CONFIG="gmetadom-config"
-GMETADOM_MIN_VERSION=0.1.0
-AC_MSG_CHECKING([for GMetaDOM C++ library] >= $GMETADOM_MIN_VERSION) 
-if test "x$GMETADOM_PREFIX" != "x"
-then
-       if ${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG --version > /dev/null 2>&1
-       then
-               GMETADOM_CONFIG=${GMETADOM_PREFIX}/bin/$GMETADOM_CONFIG
-        elif ! $GMETADOM_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR([Could not find gmetadom anywhere (see config.log for details).])
-       fi
-fi
-
-dnl
-dnl test version and init our variables
-dnl
-vers=`$GMETADOM_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $GMETADOM_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        GMETADOM_LIBS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --libs`"
-        GMETADOM_CFLAGS="`$GMETADOM_CONFIG --module=gdome_cpp_smart --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR([You need at least GMetaDOM (C++) $GMETADOM_MIN_VERSION for this version of $PACKAGE])
-fi
+dnl PKG_CHECK_MODULES(GLIB2, glib-2.0)
+dnl AC_SUBST(GLIB2_CFLAGS)
+dnl AC_SUBST(GLIB2_LIBS)
 
+PKG_CHECK_MODULES(GMETADOM,gdome2-cpp-smart)
 AC_SUBST(GMETADOM_CFLAGS)
 AC_SUBST(GMETADOM_LIBS)
 
-GDOMEXSLT_CONFIG="gdome_xslt_cpp_smart-config"
-GDOMEXSLT_MIN_VERSION=0.0.4
-AC_MSG_CHECKING([for gdome_xslt C++ library] >= $GDOMEXSLT_MIN_VERSION) 
-if test "x$GDOMEXSLT_PREFIX" != "x"
-then
-       if ${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG --version > /dev/null 2>&1
-       then
-               GDOMEXSLT_CONFIG=${GDOMEXSLT_PREFIX}/bin/$GDOMEXSLT_CONFIG
-        elif ! $GDOMEXSLT_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR([Could not find gdome_xslt anywhere (see config.log for details).])
-       fi
-fi
-
-dnl
-dnl test version and init our variables
-dnl
-vers=`$GDOMEXSLT_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $GDOMEXSLT_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        GDOMEXSLT_LIBS="`$GDOMEXSLT_CONFIG --libs`"
-        GDOMEXSLT_CFLAGS="`$GDOMEXSLT_CONFIG --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR([You need at least gdome_xslt (C++) $GDOMEXSLT_MIN_VERSION for this version of $PACKAGE])
-fi
-
+PKG_CHECK_MODULES(GDOMEXSLT,gdome2-xslt-cpp-smart)
 AC_SUBST(GDOMEXSLT_CFLAGS)
 AC_SUBST(GDOMEXSLT_LIBS)
 
-GTKMATHVIEW_CONFIG="gtkmathview-config"
-GTKMATHVIEW_MIN_VERSION=0.4.0
-AC_MSG_CHECKING([for gtkmathview library] >= $GTKMATHVIEW_MIN_VERSION) 
-if test "x$GTKMATHVIEW_PREFIX" != "x"
-then
-       if ${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
-       then
-               GTKMATHVIEW_CONFIG=${GTKMATHVIEW_PREFIX}/bin/$GTKMATHVIEW_CONFIG
-        elif ! $GTKMATHVIEW_CONFIG --version > /dev/null 2>&1
-        then
-               AC_MSG_ERROR([Could not find gtkmathview anywhere (see config.log for details).])
-       fi
-fi
-
-dnl
-dnl test version and init our variables
-dnl
-vers=`$GTKMATHVIEW_CONFIG --version | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-minvers=`echo $GTKMATHVIEW_MIN_VERSION | awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
-if test "$vers" -ge "$minvers"
-then
-        GTKMATHVIEW_LIBS="`$GTKMATHVIEW_CONFIG --libs`"
-        GTKMATHVIEW_CFLAGS="`$GTKMATHVIEW_CONFIG --cflags`"
-        AC_MSG_RESULT(found)
-else
-        AC_MSG_ERROR([You need at least gtkmathview $GTKMATHVIEW_MIN_VERSION for this version of $PACKAGE])
-fi
-
+PKG_CHECK_MODULES(GTKMATHVIEW,gtkmathview-gmetadom)
 AC_SUBST(GTKMATHVIEW_CFLAGS)
 AC_SUBST(GTKMATHVIEW_LIBS)
 
@@ -218,6 +146,7 @@ else
   OCAMLMKLIB=ocamlmklib
   AC_SUBST(OCAMLMKLIB)
 fi
+AM_CONDITIONAL(HAVE_SHAREDLIBS_COND, test x$enable_shared = xyes)
 
 AC_MSG_CHECKING(for gdome2 ocaml binding)
 ocamlfind query gdome2 ||
@@ -236,14 +165,23 @@ AC_CHECK_FILE(/usr/include/caml/mlvalues.h,
 
 AC_SUBST(OCAML_INCLUDE_DIR)
 
+if test $profile = yes; then
+       CFLAFS="$CFLAGS -O0 -pg"
+       CXXFLAGS="$CXXFLAGS -O0 -pg"
+       AC_DEFINE(ENABLE_PROFILE,,[Define to 1 to let the widget collect some information for profiling purposes])
+fi
+
 AC_CONFIG_FILES([
  Makefile 
  src/Makefile
+ src/config.dirs
  test/Makefile
  textomml/Makefile
  textomml/config.dirs
  ocaml/Makefile
- editex-config
+ ocaml/META
+ editex.pc
+ xsl/Makefile
+ dict/Makefile
 ])
-AC_CONFIG_COMMANDS([default],[[chmod +x editex-config]],[[]])
 AC_OUTPUT