]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/ocaml/Makefile.am
This commit was manufactured by cvs2svn to create branch 'moogle'.
[helm.git] / helm / DEVEL / mathml_editor / ocaml / Makefile.am
diff --git a/helm/DEVEL/mathml_editor/ocaml/Makefile.am b/helm/DEVEL/mathml_editor/ocaml/Makefile.am
deleted file mode 100644 (file)
index 28982ba..0000000
+++ /dev/null
@@ -1,90 +0,0 @@
-PKGNAME = mathml-editor
-ARCHIVE = mlmathml-editor
-REQUIRES = gdome2 gdome2-xslt
-OCAMLFIND = @OCAMLFIND@
-OCAMLFLAGS = -I $(top_srcdir)/ocaml
-OCAMLC = $(OCAMLFIND) @OCAMLC@ $(OCAMLFLAGS) -package "$(REQUIRES)"
-OCAMLOPT = $(OCAMLFIND) @OCAMLOPT@ $(OCAMLFLAGS) -package "$(REQUIRES)"
-OCAMLDEP = $(OCAMLFIND) @OCAMLDEP@ $(OCAMLFLAGS) -package "$(REQUIRES)"
-if HAVE_SHAREDLIBS_COND
-OCAMLMKLIBFLAGS = 
-else
-OCAMLMKLIBFLAGS = -custom
-endif
-OCAMLMKLIB = @OCAMLMKLIB@ $(OCAMLMKLIBFLAGS)
-DLL = dll$(ARCHIVE).so
-OCAMLSTDLIBDIR = $(DESTDIR)/@OCAMLSTDLIBDIR@
-OCAMLSTUBDIR = $(DESTDIR)/@OCAMLSTUBDIR@
-OCAMLINSTALLDIR = $(OCAMLSTDLIBDIR)/$(PKGNAME)
-MODULES = i_mathml_editor mathml_editor
-INIT =
-CMI_S = $(MODULES:%=%.cmi)
-CMO_S = $(MODULES:%=%.cmo)
-CMX_S = $(MODULES:%=%.cmx)
-O_S = ml_mathml_editor.o c_mathml_editor.o
-LO_S = $(O_S:%.o=%.lo)
-SHARED_LIBS = $(GMETADOM_LIBS) $(GDOMEXSLT_LIBS) -lmlgdome2-xslt -lmlgdome -lstdc++ -L$(top_builddir)/src/.libs/ -leditex
-BYTE_STUFF = i_mathml_editor.cmi mathml_editor.cmi $(ARCHIVE).cma $(DLL) lib$(ARCHIVE).a
-NATIVE_STUFF = $(ARCHIVE).cmxa $(ARCHIVE).a
-BYTE_INSTALL_STUFF = $(BYTE_STUFF) META mathml_editor.mli
-NATIVE_INSTALL_STUFF = $(NATIVE_STUFF)
-
-EXTRA_DIST =   \
-       META.in mathml_editor.ml mathml_editor.mli i_mathml_editor.ml   \
-       c_mathml_editor.h .depend
-
-if HAVE_OCAMLOPT_COND
-noinst_DATA = $(BYTE_STUFF) $(NATIVE_STUFF)
-else
-noinst_DATA = $(BYTE_STUFF)
-endif
-
-noinst_LTLIBRARIES = libmlmathml-editor.la
-libmlmathml_editor_la_SOURCES = \
-  c_mathml_editor.cc \
-  ml_mathml_editor.c
-
-if HAVE_OCAMLOPT_COND
-install-data-local:    $(BYTE_INSTALL_STUFF) $(NATIVE_INSTALL_STUFF)
-else
-install-data-local:    $(BYTE_INSTALL_STUFF)
-endif
-       $(mkinstalldirs) $(OCAMLSTDLIBDIR) $(OCAMLSTUBDIR)
-       chmod -x $(DLL)
-       $(OCAMLFIND) install -destdir $(OCAMLSTDLIBDIR) $(PKGNAME) $^
-       ln -fs $(DLL) $(OCAMLSTUBDIR)/lib$(ARCHIVE).so
-
-CLEANFILES =   \
-       $(ARCHIVE).{cma,cmxa,a} $(CMI_S) $(CMO_S) $(CMX_S) ml_mathml_editor.o   \
-       $(DLL) $(INIT).cm[iox] libmlmathml-editor.a
-
-INCLUDES =     \
-       $(GDOME_CFLAGS) $(MLGDOME_CFLAGS) \
-       $(GMETADOM_CFLAGS) $(GDOMEXSLT_CFLAGS) \
-       -I$(top_srcdir)/src
-
-$(ARCHIVE).cma: $(CMO_S)
-       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMO_S) $(SHARED_LIBS)
-
-$(ARCHIVE).cmxa: $(CMX_S)
-       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMX_S) $(SHARED_LIBS)
-
-$(DLL) $(ARCHIVE).a: $(O_S)
-       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(SHARED_LIBS) $(O_S:%.o=.libs/%.o)
-
-%.cmi: %.mli
-       $(OCAMLC) -c $<
-%.cmo %.cmi: %.ml
-       $(OCAMLC) -c $<
-%.cmx: %.ml %.cmi
-       $(OCAMLOPT) -c $<
-
-i_mathml_editor.cmo: i_mathml_editor.ml
-       $(OCAMLC) -c $<
-i_mathml_editor.cmx: i_mathml_editor.ml
-       $(OCAMLOPT) -c $<
-
-depend: *.ml
-       $(OCAMLDEP) *.ml *.mli >.depend
-include .depend
-