]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/ocaml/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / ocaml / Makefile.am
index 624f1644f31889e24c271d3bda78d6fc1f46b2c4..28982ba252f99ec12db4252d9147cd562bf7c528 100644 (file)
@@ -23,14 +23,14 @@ CMO_S = $(MODULES:%=%.cmo)
 CMX_S = $(MODULES:%=%.cmx)
 O_S = ml_mathml_editor.o c_mathml_editor.o
 LO_S = $(O_S:%.o=%.lo)
-SHARED_LIBS = $(GMETADOM_LIBS) $(GDOMEXSLT_LIBS) -lmlgdome2-xslt -lmlgdome
-BYTE_STUFF = i_mathml_editor.cmi mathml_editor.cmi $(ARCHIVE).cma $(DLL)
+SHARED_LIBS = $(GMETADOM_LIBS) $(GDOMEXSLT_LIBS) -lmlgdome2-xslt -lmlgdome -lstdc++ -L$(top_builddir)/src/.libs/ -leditex
+BYTE_STUFF = i_mathml_editor.cmi mathml_editor.cmi $(ARCHIVE).cma $(DLL) lib$(ARCHIVE).a
 NATIVE_STUFF = $(ARCHIVE).cmxa $(ARCHIVE).a
-BYTE_INSTALL_STUFF = $(BYTE_STUFF) META
+BYTE_INSTALL_STUFF = $(BYTE_STUFF) META mathml_editor.mli
 NATIVE_INSTALL_STUFF = $(NATIVE_STUFF)
 
 EXTRA_DIST =   \
-       META.in mathml_editor.ml i_mathml_editor.ml     \
+       META.in mathml_editor.ml mathml_editor.mli i_mathml_editor.ml   \
        c_mathml_editor.h .depend
 
 if HAVE_OCAMLOPT_COND
@@ -69,15 +69,8 @@ $(ARCHIVE).cma: $(CMO_S)
 $(ARCHIVE).cmxa: $(CMX_S)
        $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMX_S) $(SHARED_LIBS)
 
-$(DLL) $(ARCHIVE).a: $(LO_S)
-       # use .lo for ocamlmklib
-       for f in $(LO_S); do    \
-               cp $$f $$f.o;   \
-       done
-       $(OCAMLMKLIB) -o $(ARCHIVE) $(GDOME_LIBS) $(LO_S:%=%.o)
-       for f in $(LO_S:%=%.o); do      \
-               rm $$f; \
-       done
+$(DLL) $(ARCHIVE).a: $(O_S)
+       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(SHARED_LIBS) $(O_S:%.o=.libs/%.o)
 
 %.cmi: %.mli
        $(OCAMLC) -c $<
@@ -92,6 +85,6 @@ i_mathml_editor.cmx: i_mathml_editor.ml
        $(OCAMLOPT) -c $<
 
 depend: *.ml
-       $(OCAMLDEP) *.ml >.depend
+       $(OCAMLDEP) *.ml *.mli >.depend
 include .depend