]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/ocaml/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / ocaml / Makefile.am
index 9c1cc707bcae5dae35f192aa514e40af83ab630f..28982ba252f99ec12db4252d9147cd562bf7c528 100644 (file)
@@ -2,10 +2,16 @@ PKGNAME = mathml-editor
 ARCHIVE = mlmathml-editor
 REQUIRES = gdome2 gdome2-xslt
 OCAMLFIND = @OCAMLFIND@
-OCAMLC = $(OCAMLFIND) @OCAMLC@ -package "$(REQUIRES)"
-OCAMLOPT = $(OCAMLFIND) @OCAMLOPT@ -package "$(REQUIRES)"
-OCAMLDEP = $(OCAMLFIND) @OCAMLDEP@ -package "$(REQUIRES)"
-OCAMLMKLIB = @OCAMLMKLIB@
+OCAMLFLAGS = -I $(top_srcdir)/ocaml
+OCAMLC = $(OCAMLFIND) @OCAMLC@ $(OCAMLFLAGS) -package "$(REQUIRES)"
+OCAMLOPT = $(OCAMLFIND) @OCAMLOPT@ $(OCAMLFLAGS) -package "$(REQUIRES)"
+OCAMLDEP = $(OCAMLFIND) @OCAMLDEP@ $(OCAMLFLAGS) -package "$(REQUIRES)"
+if HAVE_SHAREDLIBS_COND
+OCAMLMKLIBFLAGS = 
+else
+OCAMLMKLIBFLAGS = -custom
+endif
+OCAMLMKLIB = @OCAMLMKLIB@ $(OCAMLMKLIBFLAGS)
 DLL = dll$(ARCHIVE).so
 OCAMLSTDLIBDIR = $(DESTDIR)/@OCAMLSTDLIBDIR@
 OCAMLSTUBDIR = $(DESTDIR)/@OCAMLSTUBDIR@
@@ -15,17 +21,17 @@ INIT =
 CMI_S = $(MODULES:%=%.cmi)
 CMO_S = $(MODULES:%=%.cmo)
 CMX_S = $(MODULES:%=%.cmx)
-O_S = ml_mathml_editor.o
-SHARED_LIBS = $(GMETADOM_LIBS) $(GDOMEXSLT_LIBS)
-BYTE_STUFF = $(ARCHIVE).cma
+O_S = ml_mathml_editor.o c_mathml_editor.o
+LO_S = $(O_S:%.o=%.lo)
+SHARED_LIBS = $(GMETADOM_LIBS) $(GDOMEXSLT_LIBS) -lmlgdome2-xslt -lmlgdome -lstdc++ -L$(top_builddir)/src/.libs/ -leditex
+BYTE_STUFF = i_mathml_editor.cmi mathml_editor.cmi $(ARCHIVE).cma $(DLL) lib$(ARCHIVE).a
 NATIVE_STUFF = $(ARCHIVE).cmxa $(ARCHIVE).a
-BYTE_INSTALL_STUFF =   \
-       i_mathml_editor.cmi mathml_editor.cmi $(ARCHIVE).cma $(DLL) META
-NATIVE_INSTALL_STUFF = $(ARCHIVE).a $(ARCHIVE).cmxa
+BYTE_INSTALL_STUFF = $(BYTE_STUFF) META mathml_editor.mli
+NATIVE_INSTALL_STUFF = $(NATIVE_STUFF)
 
 EXTRA_DIST =   \
-       META.in mathml_editor.ml i_mathml_editor.ml     \
-       ml_mathml_editor.h c_mathml_editor.h .depend
+       META.in mathml_editor.ml mathml_editor.mli i_mathml_editor.ml   \
+       c_mathml_editor.h .depend
 
 if HAVE_OCAMLOPT_COND
 noinst_DATA = $(BYTE_STUFF) $(NATIVE_STUFF)
@@ -33,17 +39,11 @@ else
 noinst_DATA = $(BYTE_STUFF)
 endif
 
-noinst_LTLIBRARIES = libmlmathml_editor.la
+noinst_LTLIBRARIES = libmlmathml-editor.la
 libmlmathml_editor_la_SOURCES = \
   c_mathml_editor.cc \
   ml_mathml_editor.c
 
-#test: test.ml $(ARCHIVE).cma
-#      $(OCAMLC) -o $@ -linkpkg $(INCLUDES) $<
-
-#test.opt: test.ml $(ARCHIVE).cmxa
-#      $(OCAMLOPT) -o $@ -linkpkg $(INCLUDES) $<
-
 if HAVE_OCAMLOPT_COND
 install-data-local:    $(BYTE_INSTALL_STUFF) $(NATIVE_INSTALL_STUFF)
 else
@@ -56,17 +56,21 @@ endif
 
 CLEANFILES =   \
        $(ARCHIVE).{cma,cmxa,a} $(CMI_S) $(CMO_S) $(CMX_S) ml_mathml_editor.o   \
-       $(DLL) $(INIT).cm[iox] libmlmathml_editor.a
+       $(DLL) $(INIT).cm[iox] libmlmathml-editor.a
 
 INCLUDES =     \
        $(GDOME_CFLAGS) $(MLGDOME_CFLAGS) \
        $(GMETADOM_CFLAGS) $(GDOMEXSLT_CFLAGS) \
        -I$(top_srcdir)/src
 
-$(ARCHIVE).cma $(DLL): $(CMO_S)
-       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMO_S) $(O_S) $(SHARED_LIBS)
-$(ARCHIVE).cmxa $(ARCHIVE).a: $(CMX_S)
-       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMX_S) $(O_S) $(SHARED_LIBS)
+$(ARCHIVE).cma: $(CMO_S)
+       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMO_S) $(SHARED_LIBS)
+
+$(ARCHIVE).cmxa: $(CMX_S)
+       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(CMX_S) $(SHARED_LIBS)
+
+$(DLL) $(ARCHIVE).a: $(O_S)
+       $(OCAMLMKLIB) -o $(ARCHIVE) -L@OCAMLSTUBDIR@ $(SHARED_LIBS) $(O_S:%.o=.libs/%.o)
 
 %.cmi: %.mli
        $(OCAMLC) -c $<
@@ -80,7 +84,7 @@ i_mathml_editor.cmo: i_mathml_editor.ml
 i_mathml_editor.cmx: i_mathml_editor.ml
        $(OCAMLOPT) -c $<
 
-depend: *.ml *.mli
+depend: *.ml
        $(OCAMLDEP) *.ml *.mli >.depend
 include .depend