]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/src/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / src / Makefile.am
index 439f23e52ea1d6d86f27fd3f631d818c0d255a0d..1f3a12ddf6070603ceb5b86a9e82720a04e95142 100644 (file)
@@ -3,9 +3,10 @@ lib_LTLIBRARIES = libeditex.la
 
 libeditex_la_LDFLAGS = -version-info @EDITEX_VERSION_INFO@
 
-libeditex_la_LDADDS = \
+libeditex_la_LIBADD = \
   $(GMETADOM_LIBS) \
-  $(GDOMEXSLT_LIBS)
+  $(GDOMEXSLT_LIBS) \
+  -lstdc++
 
 libeditex_la_SOURCES = \
   Diff.cc \
@@ -16,12 +17,14 @@ libeditex_la_SOURCES = \
   LPushLexer.cc \
   APushParser.cc \
   TPushParser.cc \
+  AMathMLFactory.cc \
   CMathMLFactoryXSLT.cc \
   CMathMLFactoryXSLTDiff.cc \
   TDictionary.cc \
   TDocument.cc \
   TNode.cc \
-  TTokenizer.cc
+  TTokenizer.cc \
+  timer.cc
 
 pkginclude_HEADERS = \
   Diff.hh \
@@ -45,7 +48,8 @@ pkginclude_HEADERS = \
   TListener.hh \
   TToken.hh \
   globals.hh \
-  dom.hh
+  dom.hh \
+  timer.hh
 
 INCLUDES = \
   $(GMETADOM_CFLAGS) \