]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/src/Makefile.am
ocaml 3.09 transition
[helm.git] / helm / DEVEL / mathml_editor / src / Makefile.am
index bfb6b97b6408fccb755b12aa60babc900273b02a..1f3a12ddf6070603ceb5b86a9e82720a04e95142 100644 (file)
@@ -3,18 +3,28 @@ lib_LTLIBRARIES = libeditex.la
 
 libeditex_la_LDFLAGS = -version-info @EDITEX_VERSION_INFO@
 
+libeditex_la_LIBADD = \
+  $(GMETADOM_LIBS) \
+  $(GDOMEXSLT_LIBS) \
+  -lstdc++
+
 libeditex_la_SOURCES = \
   Diff.cc \
   CLoggerConsole.cc \
+  ITPushLexer.cc \
+  ILPushLexer.cc \
   TPushLexer.cc \
+  LPushLexer.cc \
   APushParser.cc \
   TPushParser.cc \
+  AMathMLFactory.cc \
   CMathMLFactoryXSLT.cc \
   CMathMLFactoryXSLTDiff.cc \
   TDictionary.cc \
   TDocument.cc \
   TNode.cc \
-  TTokenizer.cc
+  TTokenizer.cc \
+  timer.cc
 
 pkginclude_HEADERS = \
   Diff.hh \
@@ -23,16 +33,25 @@ pkginclude_HEADERS = \
   APushLexer.hh \
   APushParser.hh \
   AMathMLFactory.hh \
+  AMathMLConsumer.hh \
   CMathMLFactoryXSLT.hh \
   CMathMLFactoryXSLTDiff.hh \
   TPushLexer.hh \
+  LPushLexer.hh \
+  ITPushLexer.hh \
+  ILPushLexer.hh \
   TPushParser.hh \
   TTokenizer.hh \
   TDictionary.hh \
   TDocument.hh \
   TNode.hh \
   TListener.hh \
-  dom.hh
+  TToken.hh \
+  globals.hh \
+  dom.hh \
+  timer.hh
 
-INCLUDES = $(GMETADOM_CFLAGS) $(GDOMEXSLT_CFLAGS)
+INCLUDES = \
+  $(GMETADOM_CFLAGS) \
+  $(GDOMEXSLT_CFLAGS)