]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mathml_editor/src/Makefile.am
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / mathml_editor / src / Makefile.am
index 4d88a334a78a3a0e325b6ce4fa25553147e1aec5..fd3ef54111d49bedd3804370c390700f3f718ce9 100644 (file)
@@ -3,18 +3,21 @@ lib_LTLIBRARIES = libeditex.la
 
 libeditex_la_LDFLAGS = -version-info @EDITEX_VERSION_INFO@
 
-libeditex_la_LDADDS = \
-  $(GLIB2_LIBS) \
+libeditex_la_LIBADD = \
   $(GMETADOM_LIBS) \
-  $(GDOMEXSLT_LIBS)
+  $(GDOMEXSLT_LIBS) \
+  -lstdc++
 
 libeditex_la_SOURCES = \
   Diff.cc \
   CLoggerConsole.cc \
+  ITPushLexer.cc \
+  ILPushLexer.cc \
   TPushLexer.cc \
   LPushLexer.cc \
   APushParser.cc \
   TPushParser.cc \
+  AMathMLFactory.cc \
   CMathMLFactoryXSLT.cc \
   CMathMLFactoryXSLTDiff.cc \
   TDictionary.cc \
@@ -29,20 +32,24 @@ pkginclude_HEADERS = \
   APushLexer.hh \
   APushParser.hh \
   AMathMLFactory.hh \
+  AMathMLConsumer.hh \
   CMathMLFactoryXSLT.hh \
   CMathMLFactoryXSLTDiff.hh \
   TPushLexer.hh \
   LPushLexer.hh \
+  ITPushLexer.hh \
+  ILPushLexer.hh \
   TPushParser.hh \
   TTokenizer.hh \
   TDictionary.hh \
   TDocument.hh \
   TNode.hh \
   TListener.hh \
+  TToken.hh \
+  globals.hh \
   dom.hh
 
 INCLUDES = \
-  $(GLIB2_CFLAGS) \
   $(GMETADOM_CFLAGS) \
   $(GDOMEXSLT_CFLAGS)