]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mlminidom/configure.in
- the mathql interpreter is not helm-dependent any more
[helm.git] / helm / DEVEL / mlminidom / configure.in
index bf6dcdcb148da1bda326ec79df7d9ae2d1c89890..8de47e4c4a645f2e2dc9da48ed4b6a709c7a5cae 100644 (file)
@@ -3,7 +3,7 @@ AC_INIT(minidom.ml)
 PACKAGE=mlminidom
 
 MLMINIDOM_MAJOR_VERSION=0
-MLMINIDOM_MINOR_VERSION=0
+MLMINIDOM_MINOR_VERSION=2
 MLMINIDOM_MICRO_VERSION=2
 MLMINIDOM_VERSION=$MLMINIDOM_MAJOR_VERSION.$MLMINIDOM_MINOR_VERSION.$MLMINIDOM_MICRO_VERSION
 VERSION=$MLMINIDOM_VERSION
@@ -23,8 +23,13 @@ if test $HAVE_OCAMLC = "no"; then
   AC_MSG_ERROR(could not find ocamlc in PATH, please make sure ocaml is installed)
 fi
 
+AC_CHECK_PROG(HAVE_OCAMLFIND, ocamlfind, yes, no)
+if test $HAVE_OCAMLFIND = "no"; then
+  AC_MSG_ERROR(could not find ocamlfind in PATH, please make sure findlib is installed)
+fi
+
 AC_MSG_CHECKING("for the ocaml library dir")
-OCAML_LIB_DIR=`ocamlc -v | grep "^Standard" | sed 's/^.*: *//'`
+OCAML_LIB_DIR=`ocamlc -where`
 AC_MSG_RESULT($OCAML_LIB_DIR)
 
 AC_CHECK_FILE(/usr/include/caml/mlvalues.h,