]> matita.cs.unibo.it Git - helm.git/blobdiff - helm/DEVEL/mlminidom/debian/rules
This commit was manufactured by cvs2svn to create branch 'init'.
[helm.git] / helm / DEVEL / mlminidom / debian / rules
diff --git a/helm/DEVEL/mlminidom/debian/rules b/helm/DEVEL/mlminidom/debian/rules
deleted file mode 100755 (executable)
index 8fac22a..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatability version to use.
-export DH_COMPAT=2
-
-UPSTREAM_CHANGELOG = ChangeLog
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-       ./configure
-
-       touch configure-stamp
-
-build: configure-stamp build-stamp
-build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE)
-       -test -x /usr/bin/ocamlopt && $(MAKE) opt
-       #/usr/bin/docbook-to-man debian/mlminidom.sgml > mlminidom.1
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/mlminidom.
-       $(MAKE) install DESTDIR=$(CURDIR)/debian/mlminidom/usr/lib/ocaml
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-#      dh_installdebconf       
-       dh_installdocs
-       dh_installexamples
-#      dh_installmenu
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installmanpages
-#      dh_installinfo
-#      dh_undocumented
-       if [ -s $(UPSTREAM_CHANGELOG) ]; then \
-               dh_installchangelogs $(UPSTREAM_CHANGELOG); \
-       else \
-               dh_installchangelogs; \
-       fi
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_perl
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure